cancel
Showing results for 
Search instead for 
Did you mean: 

Web Intelligence Session Timeout

Former Member
0 Kudos
3,459

I am running Business Objects XI R2 SP2 and running Xcelsius 2008 FP1.

Basically within my models i use LiveOffice to refresh the initial data used within the models and then I use QaaWS to use certain drill through parameters to retrieve more detailed information.

All this works fine and returns all the data i need, but i get session errors when accessing the models from Infoview.

When i log into Infoview, i can run 1 model fine and do all the necessary refreshes and further drill downs without any trouble, but when i close the model down and try to go into the next model i get the following error message;

Your webintelligence session has timeed out WIS: 30553.

NOw i have updated all the setting i know of eg;

1) Webi report server timeout in server properties

2) Configured the command line of the webi report server in CCM to include the timeout parameter.

3) Web.xml file has been amended to increase the session timout

4) Web.xml file has been amended to uncomment the listener settings

5) i have even updated the session timeout on the Tomcat server (tomcat\conf\web.xml)

Has anyone any other ideas as i can not access the models

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Anthony,

Following solutions might be helpful for resolving the issue.

Solution1:

All the system concurrent user access licenses are in use.

Solution

Contact licensing for additional licenses or wait until a license becomes available.

A list of logged on users can be checked in the Centtral Management Console by clicking Servers > CMS (Properties).

The problem is with sessions which time out and then is never able to log back in without restarting the Web Intelligence servers.

Solution2:

1) Add the following lines to the web.xml file.

The "web.xml" is a static file contained in the Tomcat "webapps" directory /BOBJE_DIR/bobje/tomcat/webapps/businessobjects/enterprise115/desktoplaunch/WEB-INF/web.xml

<listener>

<listener-class>com.businessobjects.sdk.ceutils.SessionCleanupListener</listener-class>

</listener>

2) This listener will explicitly log off the session objects when they are invalidated.

Solution3:

This error message appears because the CMS and Job Server are not synchronized. To resolve this error message, ensure that all computers in the cluster are time synchronized.

I hope this will help you.

Regards,

Sarbhjeet Kaur

Former Member
0 Kudos

We only have 5 concurrent licences but when we have breached that i get a different error message.

I have already added the listener to the web.xml file.

All the internal BO servers are on the same server, so clustering is not an issue.

It is just very weird why it only affects Xcelsuis models rather than actual Webi reports?

Former Member
0 Kudos

We are getting innvalid session error messages too. I have timeouts set in web.xml webiproc servers to 120 minutes and still getting the error when the report is running. I sw your note in this thread where you mentioned to sync time on both clusters.

How do you sync the time in the clustered environemnt? thanks!

Former Member
0 Kudos

Hi,

To sync time on both clusters we need to set the same time for all the servers in the cluster.

Regards,

Sarbhjeet Kaur

Former Member
0 Kudos

If the previous solutions provided are not helpful then you can try the following one.

You may have to increase the default time-out value for persistent HTTP connections in Internet Explorer if you are using a Web program that must communicate with Internet Explorer over the same TCP/IP socket after one idle minute. To change the default time-out value for persistent HTTP connections in Internet Explorer, add a DWORD value that is named KeepAliveTimeout to the following registry key, and then set its value data to the time (in milliseconds) that you want Internet Explorer to wait before resetting an idle connection:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings

To do this, follow these steps:

1.Click Start, click Run, type regedit, and then click OK.

2.Locate and then click the following key in the registry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings

3.On the Edit menu, point to New, and then click DWORD Value.

4.Type KeepAliveTimeout, and then press ENTER.

5.On the Edit menu, click Modify.

6.Type the appropriate time-out value (in milliseconds), and then click OK. For example, to set the time-out value to two minutes, type 120000.

7.Restart Internet Explorer.

If you set the KeepAliveTimeout value to less than 60,000 (one minute), you may have problems communicating with Web servers that require persistent HTTP connections. For example, you may receive a "Page cannot be displayed" error message.

If you must have a KeepAliveTimeout value higher than 120000 (two minutes), you must create an additional registry key and set its value equal to the KeepAliveTimeout value that you want. The additional registry key is ServerInfoTimeout. It is a DWORD with a value (in milliseconds) and in the same location as KeepAliveTimeout.

For example, to use a three-minute KeepAliveTimeout value, you must create the following registry keys:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings

KeepAliveTimeout DWORD value 180000 (in milliseconds)

ServerInfoTimeout DWORD value 180000 (in milliseconds)

By default, HTTP 1.1 is enabled in Internet Explorer except when you establish an HTTP connection through a proxy server. When HTTP 1.1 is enabled, HTTP connections remain open (or persistent) by default until the connection is idle for one minute or until the value that is specified by the KeepAliveTimeout value in the registry is reached. You can modify HTTP 1.1 settings in Internet Explorer by using the Advanced tab in the Internet Options dialog box.

Regards,

Sarbhjeet Kaur

Former Member
0 Kudos

Hi Sarbhjeet,

I did find your previous post on this, but the trouble is, the session is not inactive at all. i click into 1 model and then come striaght out and click into the next one and the error message is displayed.

When i go into webi reports i can move around without an issues at all. I can open up a report refresh it, close it down and go into another report and refresh and all is ok, so i think it is related to Xcelsius??

Regards,

Anthony

Former Member
0 Kudos

Hi Anthony,

Following solutions might be helpful for resolving the issue.

Solution1:

If you are using .net, please perform following settings

- Right mouse click on "My Computer" and select "Manage"

- Expand "Services and Applications"

>> "Internet Information Services"

>> "Web Sites"

- Right mouse click on "Default Web Site" and select "Properties"

- Increase "Connection Timeout" from 120 seconds to 3600 seconds

- Next click the "Home Directory" tab and click the "Configuration" button

- Under the "Options" tab, increase the ASP Script timeout to 600 seconds

Solution2:

Go to Start > Settings > Control Panel > System > Advanced > Enviromental Variables and under both User and System variables change the TEMP and TMP variables to the same location.

Solution3:

Click Start > Run. The Run dialog box appears.

Type "regedit" in the Open text field. Click OK. The Registry Editor appears.

Navigate to the HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Session Manager.

Click Subsystems > right-click Windows key > click Modify.

Edit the SharedSection value from 1024,3072,512 to 1024,3072,1024.

Solution4:

Webi Report Server

Enable the following

  • List of values caching

  • Enable Viewing Caching

  • Enable Real time Caching

- Increase 'Document Cache Duration'

- Increase 'Document Cache Size'

- Increase 'Document Cache Scan Interval'

- 'Document Cache Duration' should always grater than 'Document Cache Scan Interval'

I hope this will help you.

Regards,

Sarbhjeet Kaur

Former Member
0 Kudos

Hi Sarbhjeet,

I have tried everything you have listed above and i still get the error message. What is strange is that i have to shut the browser down and log back into Infoview to gain access.

I can not use the log on button and log back in as when i do that i get the error when i click on the first model.

regards,

anthony

Former Member
0 Kudos

Hi Anthony,

Following settings might help you resolve the issue.

1. CORBA

-requestTimeout

This is the default CORBA timeout which can be set on any BOE services through command lines in CCM. And this switch is in millisecond.

Registry CORBA Timeout

This is a default hard coded 10 mins timeout for CORBA. WebI and DeskI did get integrated into this regkey:

(1) Go to HEKY_LOCAL_MACHINE -> SOFTWARE -> Business Objects -> Suite 11.5 -> CER.

(2) Modify ConnectionTomeout from 600000 to higher value.

(3) Restart all services in CCM.

2. Infoview Java Application (For example, Tomcat) Session Timeout If a user idles in Infoview for longer than this timeout, the session will be killed automatically. The default session timeout is 20 mins. To change the default session time out for InfoView:

(1) Go to u201Cu2026\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch\WEB-INF\web.xmlu201D

(2) Modify web.xml. Scroll to the following section:

<session-config>

<session-timeout>20</session-timeout>

</session-config>

(3) Edit the <session-timeout> value to the desired value. Save the web.xml file.

(4) Restart Tomcat.

If you meet their sessions are not getting released when they log out, here are two things to check in web.xml:

(1) If the below configuration was set by true, that means they will have another session allocated to them once they begin to move around in Infoview after the user times out. If it was

set by false, the user have to re-logon after they times out.

<context-param>

<param-name>logontoken.enabled</param-name >

<param-value>true</param-value >

</context-param>

(2) All sessions will be cleanup after they times out if uncommented the below configuration. If you are having issues with sessions staying in CMS, try to uncomment the below line and

restart tomcat.

<listener>

<listener-class>com.businessobjects.sdk.ceutils.SessionCleanupListener

</listener-class>

3. Tomcat

ConnectionTimeout

The default value is 20000 milliseconds. To disable it, try to set the value to -1 as below:

(1) Go to u201Cu2026\Tomcat\conf\server.xmlu201D.

(2) Find line u201CConnector on port 8080u201D.

(3) Modify connectiontomeout = u201C20000u201D to ConnectionTimeout = u201C-1u201D.

4. Universes

Execution Timeout

(1) Go to Universe Designer -> File -> Parameters -> Controls.

(2) Check the value of u201CLimit execution time tou201D.

5. WebI

Connection Timeout

The number of minutes before an idle connection to the WebI Report Server will be closed. When Java Report Panel, it is now controlled by this timeout switch:

(1) Log into CMC

(2) Go to Servers -> WebI Report Server

(3) Set Connection Timeout

WebI Report Timeout

WebI designers have the ability to set a limit on how long a query can be run on a database before the query is stopped:

(1) Edit/Create a new WebI report using Java Report Panel.

(2) Choose Edit Query -> Properties.

(3) Now deselect/increase the "max retrieval time" value.

Swap Timeout

In Java Report Panel and you leave it idle for more than 5 minutes (Default), you will notice that you will no longer be able to save your WebI report into CMS or your report will take longer

to generate. This is because SwapTimeOut setting which controls the flushing interval of WebI temp files:

(1) HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.5\default\WebIntelligence\Server\Admin\SwapTimeOut

Regards,

Sarbhjeet Kaur