cancel
Showing results for 
Search instead for 
Did you mean: 

Webi Report timeout settings

0 Kudos
1,088

Hi,

I have a requirement to increase my timeout settings to 30 min for a particular webi report

so i increased the following

Timeout Before Recycling (seconds)-- 2400

idle Document Timeout (seconds)--2400

Idle Connection Timeout (minutes):40

Single Sign-On Expiry (seconds) : 86400(default)

I checked the settings under CMS , WebiDSL and ConnectionServer also and increased them to 2400 atleast.

For some reason my report still gets timed out error around 15 min. it still takes the 1200 seconds which is default and timesout.


I have restarted SIA and also made chagnes to web.xml file under tomcat>webapps>BOE to make sure and restarted the tomcat.

Can you please let me know if i have to make changes else where . Previously the 4 places i made changes always worked

We are on 4.2 SP03 and with windows AD connections


Accepted Solutions (0)

Answers (4)

Answers (4)

wobi
Participant
0 Kudos

The general Web - Application Timeout would be set in Tomcat web.xml and is 20 min by default.

- Wobi

0 Kudos

i set RequestedTimeout in webi server command line to 3600000 but even that didnt help.

former_member185603
Active Contributor
0 Kudos

Can you schedule the report and see if the report ran successfully without any issues?

0 Kudos

yes, i don't have an issue that way. It runs fine. We run into issue when an end user wants to add few more varaibles into the report which makes it run for more time and then eventually timeouts if not monitored . Increasing it to 30 min would help but for some reason its not working.

Should I wdeploy by infoview file after making changes to the web.xml file?

former_member185603
Active Contributor
0 Kudos

Is the report based on universe, make sure Universe settings also set to properly. And also can you schedule the report and see if the issue is with timeout at webi server or Universe level?

0 Kudos

Hi Jawahar,

I already changed universe settings to an hr