cancel
Showing results for 
Search instead for 
Did you mean: 

Eclipse Pop-Up: Compatibility Patch Level Mismatch

alexanderbrietz
Active Contributor
0 Kudos

Hi experts,

since a couple of weeks I am getting this pop-up when I log onto my SAP IdM instance:



I know about the Patch Level Mismatch and I have to stick to certain restrictions in terms of update of my AS Java instance which is quiet common in entrerprise environments.

What I am looking for is information about how to handle this:

- Where can I find the needed compatibility patch level definition to follow?

- When Eclipse reminds me about a new patch for SAP IdM Plugin, what should I do? What are the restrictions?

- Once installed Eclipse reminds me with every login about the fact that the versions do not match. Is there a way to get rid of this reminder other than upgrading the AS Java?

Any hints are welcome.

Regards,

Alex

Accepted Solutions (0)

Answers (3)

Answers (3)

todor_petrov
Contributor

Hi Alex,

SAP released one note, which explains how to downgrade the Dev. Studio plugin.

See if it helps. Unfortunately, if not, there is no other workaround (at least officially)

2450996 - How to revert to an older patch of the IDM Developer Studio - SAP ONE Support Launchpad

https://launchpad.support.sap.com/#/notes/3115314

The last one is for some reason not available right now, but i suppose they will update it and release.

BR,

Todor

alexanderbrietz
Active Contributor
0 Kudos

Hi Todor,

thanks for your answer and the provided notes. I know about reverting Eclipse plug-in, but this does not answer my questions. It certainly is another workaround.

Regards,

Alex

Henrik1
Participant
0 Kudos

Hi, I am trying to find an older version of the plugin, as I have a recently upgraded laptop without the older plugin installed. Any thoughts on where I might be able to locate this?

alexanderbrietz
Active Contributor

Hi Hendrik,

usually you can select the older plugin version from update location when you deselct the relevant options "Show only the latest versions of available software" and "Hide items that are already installed".

But when I tried it today I only got the current version.

As an alternative you could download the older plugin version from SWDC:

After that you can deploy it in Eclipse using "Update from file" option.

Regards,

Alex

slavenat
Advisor
Advisor
0 Kudos

Hi Alex,

Let me answer your questions briefly:

Q: Where can I find the needed compatibility patch level definition to follow?

A: For now, we do not provide any information on dependent versions.

Q: When Eclipse reminds me about a new patch for SAP IdM Plugin, what should I do? What are the restrictions?

A: You should always make sure that both your IDM Eclipse plugin and the IDM DevStudio Rest API are updated to the latest version. If you receive this pop-up, this means that one of those components is not updated. If you continue working in this mode without updating the Dev Studio components, some functionalities may work incorrectly or some errors may pop-up at a later point.

Q: Once installed Eclipse reminds me with every login about the fact that the versions do not match. Is there a way to get rid of this reminder other than upgrading the AS Java?

A: No, there is no way to avoid receiving this message.

Best regards,

Slavena