cancel
Showing results for 
Search instead for 
Did you mean: 

SAPSprint could not start

0 Kudos

I have Win Server 2008 R2 and for some reason the SAP sprint service stops and cant start again. When I try to start it manually it says "Error 1053: The service did not start or control request in a timely Fashion"

I did change the registry Key to increase the time to start a service with no success. The only solution I have is to reinstall the service every time it fails.

Matt_Fraser
Active Contributor
0 Kudos

Hi Katty,

Welcome to the SAP Community! You'll note that I have adjusted the tags on your question to better reflect the subject. This should help improve its visibility by getting it in front of the right audience.

Regards,
Matt Fraser
SAP Community Moderator

Accepted Solutions (0)

Answers (4)

Answers (4)

ssuratharajan
Participant
0 Kudos

Try checking the event viewer logs in Windows for a high clarity on why the service failed to start. This should help you in getting some directions whether it is a Security or a Service issue in windows to troubleshoot further.

0 Kudos

After an inplace upgrade from Windows Server 2012 R2 to Server 2019 the sapsprint service not starting anymore.

I check the log files and found the problem - Network port already in use:

(12.04.2023 10:57:06) Error: The TCP port (515) for SAPSprint is in use.

(12.04.2023 10:57:06) Error: TCP/IP communication could not be started - aborting.

With "netstat -aof | findstr :515" i found a service they already used the port 515
The LPDSVC (One of many svchost.exe) are the problem! In CMD you could the the PID and locate them via the task manager.
Set the start type of LPDSVC to "manual" and stop the service - Then you could start the SAPSprint service again 🙂
S_Sriram
Active Contributor

Hi Marcel

Create a separate thread so that it will use by others. is this firewall blocking port 515? Have tried the latest version of SAPSprint?

Regards

SS

0 Kudos

Hi Siriram,

I post a solution, not an question 😉

0 Kudos

Hi Rios,

This usually happens when there is an outdated Windows Server. Please ensure that the Windows Server has all the latest patches, especially the Visual C++ Redistributable runtime for DLLs.

Moreover, Windows 2008 R2 is nearing its end of mainstream maintenance by Microsoft by the end of this year. Better you should deploy the latest SAPSprint on Windows 2012 or higher. Refer to the following SAP Note.

2795810 - SAPSprint 760 Patch 1

Regards,

Prateek

S_Sriram
Active Contributor
0 Kudos

Hi Rios.

1. In the windows services - SAPSprint properties set to "starting type: Automatic (Delayed start)" and check the service startup status.

2. Try to update the latest version of SAPSprint from SAP Service market place. if you are using old version it may having starting issue.

Regards

SS