Showing results for 
Search instead for 
Did you mean: 

CR not displaying certain characters.

Former Member
0 Kudos


I hope this is the best forum for my question/problem otherwise would appreciate a push in the right direction.

Working in Eclipse 3.4.1

Crystal Reports for Eclipse v2.0.4.r825

Oracle9i Enterprise Edition Release

NLS_Characterset: EE8ISO8859P2

The situation is that I am working with a DB that has Slovakian characters in it.

For example "Hodžovo námestie 3" The ž is not being handled correctly.

If I setup a database connection using the Oracle Thin driver (ojdbc14.jar) I get ? returned on the report in place of the ž or

if I try browse the data by right clicking on the specific column in the "Data" screen, I get a square instead.

If I copy the text into a text box, it can display correctly on the report so this leads me to believe it is not the font settings

that are causing the problems, but rather how the database drivers are interpreting the specific character.

I have tried playing around with the NLS but I have not had too much luck.

The NLS_LANGUAGE item in the registry is "ENGLISH_UNITED KINGDOM.EE8ISO8859P2" so as far as I can tell all enviromental

references to character set are all correctly set to ISO-8859-2.

If I run a SQL query in SLQ*Plus Worksheet, I get the correct string returned : "Hodžovo námestie 3" so I know the data in the

database is stored correctly.

Can anyone give me an idea of what I am doing wrong, what I need to do to solve the problem,

or if you need more info can you tell me what you need and how to get it for you?

Any help would be greatly appriciated.



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos


Create a table with variable as Nvarchar and try..It solved the problem for me

Answers (1)

Answers (1)

0 Kudos

Hi Darren,

Actually the best place for this is the Java SDK forum so I moved your post.

Thank you


Former Member
0 Kudos

Thanks Don,

I decided to try another approach, and created a SQL Scrapbook with the following SQL:


Now the result I get when running the same SQL using the exact same conneciton details on SQL*Plus Worksheet is:


but if I run it through Eclipse and SQL Scrapbook I get the result:


Dont know if that gives anyone some ideas, I will see what my DBA thinks if I can get hold of him.

Former Member
0 Kudos

It sounds like you are talking about a couple of different issues; the ? and little square in the report may be because the font character is not part of the WIN ANSI 1521 CodePage. If this is the case then there is nothing that can be done; the CRJ will only correctly view characters within that code page, as well as some of the asian character sets.

The part about the SQL Scrapbook doesn't sound like the same issue.... perhaps you are correct in that your DBA could give you some insight into that one.