cancel
Showing results for 
Search instead for 
Did you mean: 

BAS extension activation error

Former Member

Anybody seen this in their BAS?

Activating extension 'vscode-mta-tools' failed: Not a valid JSON output: INFO: Running mta for the first time; downloading the actual binary (node:281) UnhandledPromiseRejectionWarning: Error: spawn ETXTBSY at ChildProcess.spawn (internal/child_process.js:403:11) at spawn (child_process.js:553:9) at execBin (/tmp/vscode-unpacked/vscode-mta-tools-1.4.0.vsix/extension/dist/bin/mta:48528:3) at /tmp/vscode-unpacked/vscode-mta-tools-1.4.0.vsix/extension/dist/bin/mta:48544:5 (Use node --trace-warnings ... to show where the warning was created) (node:281) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1) (node:281) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code. Unexpected token I in JSON at position 0

it's an annoyance more than anything.

0 Kudos

I have similar issue.

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

Hi Raya,

1. Yes.

2. No.

3. No.

4. Extensions cannot be added as the icon is not loading on the left hand side bar.

Does this makes sense?

P.S. just one more update. i keep seeing this message which i'm puzzled to understand better:

Cannot Open the Dev SpaceThe dev space you tried to open does not exist. 

Select another dev space.
0 Kudos

Hi greg,

Perhaps something's wrong with this dev space, if it reproduces on every loading it might be helpful to make a screen sharing session to debug the issue and try to find the root cause.

Please email me (raya.koren@sap.com) the time zone you're at, and I'll schedule a meeting.

Raya.

Former Member
0 Kudos

Hi Raya,

glad to hear that the central issue has been resolved, any ETA on the original issue?

Thank you,

greg

0 Kudos

Hi greg,

I find it hard to reproduce the issue on my environment.

Couple of questions to help figure out the problem:

1. Does it happen on every loading of Business Application Studio?

2. Does refresh help?

3. Does it happen on other dev spaces as well?

4. What type of dev space does it happen on? any extensions you added (besides the default ones)?

Thanks,

Raya.

0 Kudos

Hi Gregory,

The last issue is not related, it was a central issue with npm and it's resolved now.

Sorry for the inconvenience.

Raya.

Former Member
0 Kudos

Hi Raya,

maybe this will help:

npm config set @sap-ux:registry https://common.repositories.sap.ondemand.com/artifactory/api/npm/uxtools/ npm config set @sap-cds:registry https://common.repositories.sap.ondemand.com/artifactory/api/npm/sap-cds/ npm config set @devx-wing:registry https://common.repositories.sap.ondemand.com/artifactory/api/npm/devx-npm-live/ yarn global add --prefix /extbin/npm/globals --global-folder /extbin/npm/globals/lib @sap/generator-fiori@1.2.1 @sapui5/generator-sapui5-templates@1.71.* FW ERROR: The @sap-cds/cds-editor failed to install because Unable to calculate tarball URL for @sap-cds/cds-editor@21.5.2 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @devx-wing/w5g-wing failed to install because Unable to calculate tarball URL for @devx-wing/w5g-wing@0.0.5-20200914133334 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @sap-ux/sap-ux-help-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-help-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . [1/4] Resolving packages... FW ERROR: The @devx-wing/vscode-java-test failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-test@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @devx-wing/vscode-java-dependency failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-dependency@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @sap-ux/sap-ux-application-modeler-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-application-modeler-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @devx-wing/vscode-redhat-java failed to install because Unable to calculate tarball URL for @devx-wing/vscode-redhat-java@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @devx-wing/vscode-java-debug failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-debug@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @sap-ux/sap-ux-annotation-modeler-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-annotation-modeler-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @devx-wing/vscode-spring-boot-tools failed to install because Unable to calculate tarball URL for @devx-wing/vscode-spring-boot-tools@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @sap-ux/sap-ux-service-modeler-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-service-modeler-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . FW ERROR: The @devx-wing/vscode-java-run failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-run@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . warning @sap/generator-fiori > yeoman-generator > mem-fs-editor > globby > fast-glob > micromatch > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated warning @sap/generator-fiori > yeoman-generator > mem-fs-editor > globby > fast-glob > micromatch > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated warning @sapui5/generator-sapui5-templates > @sap/consume-services > @sap/wing-service-explorer > request@2.88.0: request has been deprecated, see https://github.com/request/request/issues/3142 warning @sapui5/generator-sapui5-templates > @sap/consume-services > @sap/wing-service-explorer > request > uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. warning @sapui5/generator-sapui5-templates > @sap/consume-services > @sap/wing-service-explorer > request > har-validator@5.1.5: this library is no longer supported [2/4] Fetching packages... [3/4] Linking dependencies... warning "@sapui5/generator-sapui5-templates > @sap/consume-services > @sap/modules-exploration > ts-node@8.1.0" has unmet peer dependency "typescript@>=2.0". [4/4] Building fresh packages... warning Error running install script for optional dependency: "/extbin/npm/globals/lib/node_modules/keytar: Command failed. Exit code: 1 Command: prebuild-install || npm run build Arguments: Directory: /extbin/npm/globals/lib/node_modules/keytar Output: prebuild-install WARN install libsecret-1.so.0: cannot open shared object file: No such file or directory npm WARN lifecycle The node binary used for scripts is /tmp/yarn--1624536369995-0.8461434618860655/node but npm is using /usr/bin/node itself. Use the `--scripts-prepend-node-path` option to include the path for the node binary npm was executed with. > keytar@7.2.0 build /extbin/npm/globals/lib/node_modules/keytar > node-gyp rebuild /bin/sh: 1: pkg-config: not found gyp: Call to 'pkg-config --libs-only-l libsecret-1' returned exit status 127 while in binding.gyp. while trying to load binding.gyp gyp ERR! configure error gyp ERR! stack Error: `gyp` failed with exit code: 1 gyp ERR! stack at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16) gyp ERR! stack at ChildProcess.emit (events.js:315:20) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:277:12) gyp ERR! System Linux 5.4.0-5-cloud-amd64 gyp ERR! command \"/usr/bin/node\" \"/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js\" \"rebuild\" gyp ERR! cwd /extbin/npm/globals/lib/node_modules/keytar gyp ERR! node -v v14.16.0 gyp ERR! node-gyp -v v5.1.0 gyp ERR! not ok npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! keytar@7.2.0 build: `node-gyp rebuild` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the keytar@7.2.0 build script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! /home/user/.npm/_logs/2021-06-24T12_06_12_315Z-debug.log" info This module is OPTIONAL, you can safely ignore this error warning "@sap/generator-fiori@1.2.1" has no binaries warning "@sapui5/generator-sapui5-templates@1.71.6" has no binaries Installation summary of Yeoman generators, global npm packages, VS Code extensions, and CLIs: Installation summary of the "ext-mckbj-trial/cds-modeller" extension (created by "SAP(MOB-MDE-MBG)"): The @sap-cds/cds-editor failed to install because Unable to calculate tarball URL for @sap-cds/cds-editor@21.5.2 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . Installation summary of the "w5g-wing/w5g-wing" extension: The @devx-wing/w5g-wing failed to install because Unable to calculate tarball URL for @devx-wing/w5g-wing@0.0.5-20200914133334 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . Installation summary of the "ext-sap-ux-trial/sap-ux-all-extensions" extension (created by "SAP(CA-UX-IDE)"): The @sap-ux/sap-ux-help-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-help-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @sap-ux/sap-ux-application-modeler-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-application-modeler-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @sap-ux/sap-ux-annotation-modeler-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-annotation-modeler-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @sap-ux/sap-ux-service-modeler-extension failed to install because Unable to calculate tarball URL for @sap-ux/sap-ux-service-modeler-extension@0.0.3316 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @sap/generator-fiori node module was installed successfully. Installation summary of the "java-dev-tools/java-dev-tools" extension: The @devx-wing/vscode-java-test failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-test@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @devx-wing/vscode-java-dependency failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-dependency@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @devx-wing/vscode-redhat-java failed to install because Unable to calculate tarball URL for @devx-wing/vscode-redhat-java@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @devx-wing/vscode-java-debug failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-debug@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @devx-wing/vscode-spring-boot-tools failed to install because Unable to calculate tarball URL for @devx-wing/vscode-spring-boot-tools@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . The @devx-wing/vscode-java-run failed to install because Unable to calculate tarball URL for @devx-wing/vscode-java-run@0.22.0 npm package. yarn info stdout: stderr: {"type":"error","data":"Received invalid response from npm."} . Installation summary of the "ext-hana-tools-trial/hana-runtime-tools" extension (created by "SAP(HAN-BAS)"): The @sap/hana-database-explorer VS Code extension was installed successfully. Installation summary of the "ui5-worklist-app/ui5-worklist-app" extension: The @sapui5/generator-sapui5-templates node module was installed successfully. Finished installing App Studio simple extensions components! Total install time: 39811 milliseconds

0 Kudos

Hi Gregory,

Thank you for reporting the issue.

We will look into it.

Regards,

Raya.