cancel
Showing results for 
Search instead for 
Did you mean: 

archiving query

Former Member
0 Kudos

HELLO,

DOES ANYONE KNOW HOW TO PROCEED IN ARCHIVING: I ran an archivng session while in test mode. and get this when trying to in production mode.

Ther are still incomplete arechiving session.

As long as there are incomplete archiving sessions, there is the risk

that data is archived more than once as not all archived data was

processed by the relevent delete program.

You should take this in account before proceeding.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

This message was moderated.

Former Member
0 Kudos

Hello,

Thank you for that answer, if you could walk me thru that though. Our Basis guy said we could manually STORE data to external . We have done that but and viewed that the data is no longer in our Quality server. However, while looking up archived data in ALO1 we find data in data base as well... Any thoughts would be helpful

Thank you

Former Member
0 Kudos

Hi,

The way an archiving session normally works is:

Write job runs: SAP creates an archiving file containing the data to be archived. This file is put into the archiving exchange directory.

Store job runs: SAP takes the archiving file from the archiving exchange directory and stores it in your external content repository.

Delete job runs: SAP deletes the data that has been archived from the database.

From the information that you're giving I think that the delete job for that archiving session hasn't run yet. Hence the data is still in the database.

To solve it, go to transaction SARA and manually schedule the delete job for the corresponding archiving session and archiving object. This will get the data deleted from the database.

If the delete job has already run then it ran in "Test mode" (not actually deleting the data from the database). Make sure that you schedule it with the variant in "Production mode".

If all the above fails, I suggest you open an SAP message so that they can help you solving the issue.

Hope this helps.

Former Member
0 Kudos

Hi,

The incomplete archiving session message is appearing because you started an archiving session (write job) but haven't run the storage or deletion jobs for that archiving session yet.

If you want that message to disappear, you need to schedule the storage and deletion jobs for that incomplete archiving session. For that click on 'Store' and 'Delete' buttons and select the incomplete archiving session (should have a yellow traffic light).

Once you have done this, you'll be able to start a new archiving session (in production mode) without the incomplete archiving session message.

Hope this helps.