Showing results for 
Search instead for 
Did you mean: 

ZBUS1001 OLD_MATERIAL_CHANGED event does not trigger?

Former Member
0 Kudos

Hi All

I extended BUS1001 to ZBUS1001 and activated old_material_changed with SWU_EWCD - Change Documents wizard.

Then I defined this as a start event in my workflow and just to get started send a mail to wf initiator. If I run the workflow on it's own, it's fine, I get the notification. The event is actively linked. The binding is faultless. In SWEC the event change document exists with no limiting Field Restrictions. However, when I run SWELS, do a MM02 change and save, the SWEL does not indicate that this event was triggered at all? I'm not sure if BUS1001 actually has the old_material_changed event, because it does not exist in our system? Someone might have deleted it? Not sure where to continue looking for the cause of no triggering? Please advise.



Accepted Solutions (0)

Answers (1)

Answers (1)

Active Contributor
0 Kudos

Hello Adrian !

BUS1001 is older version to BUS1001006.So, I suggest you to use BUS1001006.

There is no event by name "old_material_changed" in BUS1001 or BUS1001006.One such event does not exist in these standard business objects.

"Old_material_changed" should be a custom event.Configure this event in SWEC rather than in SWU_EWCD for "On change" for the change document "MATERIAL" and check whether workflow gets triggered.

If it is not triggering, the only option is to find the suitable BAdI or user exit for the requirement.