cancel
Showing results for 
Search instead for 
Did you mean: 

You are not authorized[...] while completing bpm task.

former_member191044
Active Contributor
0 Kudos

Hello community,

i am facing a strange problem while completing bpm tasks. System is 7.3.1 SP5. User opens bpm task out of UWL or directly via link out of a email. The task UI is a WD4J component. Claiming works fine, UI is shown and user can work with it but on completion, an exception occours and the task does not complete and stays in the UEL. All the WD4J logic on completion is executed correctly before the exception occours. This only happens in about 1 out of 100 cases and i can not recreate it on purpose. Anyway this is very very annoying in the productiv system since the user thinks the task is completed correctly and clicks it away. By the way, the user ofcourse is authorized via relevant bpm roles and can complete other tasks as well.

Here a part of the stacktrace:

Thanks for your help.

BR Tobias.

Accepted Solutions (0)

Answers (2)

Answers (2)

ch_loos
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Tobias,

you can get this error if the task was already claimed/completed/cancelled by someone else in the meantime. We have improved the error message accordingly with 7.31 SP08 and higher.

Regards,

Christian

former_member191044
Active Contributor
0 Kudos

Hi Christian,

Thanks for your input. But it is not very likely that the task was claimed/completed/cancelled by someone else since it still exists after getting this exception. Also process is running and the process marker doesn't move on. So i don't think this is the problem i face.

Regards,

Tobi

ch_loos
Product and Topic Expert
Product and Topic Expert
0 Kudos

Ok, in that case I would suggest opening an OSS ticket.

Christian

Former Member
0 Kudos

Hi Tobias,

Can you check note# http://service.sap.com/sap/support/notes/1629980

Mahesh

Vasilis
Advisor
Advisor
0 Kudos

Hi Tobias,

we had a similar behavior in SP5 with WD4A when the user opened the task directly from the email link. Can you check if this is your case too?

Regards,

Vasilis

former_member191044
Active Contributor
0 Kudos

Thank you for your reply Vasilis,

this does not seem to be the problem here. It happens in both ways (UWL / Maillink). But it only in about 1 of 100 cases. What exactly was your issue? You got exception when opening task or also only when trying to complete? You don't have this issue with higher SP now or what was your solution?

Thanks,

Tobias.

Vasilis
Advisor
Advisor
0 Kudos

Hi Tobias,

  the task was opening successful and the WD was working fine. But the triggering of the completion event was not possible.

  It was fixed with patches as described in note 1811953 - Direct link to task execution UI does not work for CHIP UI

Regards,

Vasilis

former_member191044
Active Contributor
0 Kudos

Ok. But this is only relevant for WD4A. Since WD4A needs Portal-Eventing for completion and the the UI is not opend in portal frame out of the mail link. So you weren't able to complete any task that was opened out of the link. I am using WD4J which basically works and only in a few cases i get that exception.

But anyway thanks for your help,

Tobi

abhijeet_mukkawar
Active Contributor
0 Kudos

Hi Tobi,

Looks very strange indeed as happens 1 in 100 cases..

In the same NWA log details, can you check the user it is trying to open the task with.

Have you tried if the error persists if you clear browser cache etc ?

-Abhijeet

former_member191044
Active Contributor
0 Kudos

Hi Abhijeet,

does not have to do anything with the cache or something. Because if i reenter the task and try it again (or any other task i have in uwl) it works. It must be a very specific state of the system or something like that. And yes, in the log there is for example my user if it happens for me. So user that can't complete is equal to the one that opened the task. Maybe i have to try my luck with SAP support but that won't be easy since i can't recreate it on purpose :/.

Regards,

Tobi.

abhijeet_mukkawar
Active Contributor
0 Kudos

Hi Tobi,

in such specific state, have you tried to read complete trace of error - if its generated ? I think deep down there should be some more details Or is it only single line of authorization error ?

-Abhijeet

former_member191044
Active Contributor
0 Kudos

I have just had another case and i found that right before the not authorized there is another log entry saying somthing of a GalaxyCowLock?!