cancel
Showing results for 
Search instead for 
Did you mean: 

XML format change?

Former Member
0 Kudos
369

Hi eXperts,

When calling a webservice(Siebel), the customer is asking for messages of this format:

<ConfirmationMessage>

<xiOutputCode&GT 200&LT/xiOutputCode>

<xiOutputMessage&GT Ok&LT/xiOutputMessage>

<\ConfirmationMessage>

They are not accepting "<" and ">", but only &lt and &gt. I've never met such problems before, has any one any ideas?

Any hints are highly appriciated.

Thanks in advance

Luis

Accepted Solutions (1)

Accepted Solutions (1)

former_member206604
Active Contributor
0 Kudos

Hi,

May be you can try doing that in Java mapping or ABAP mapping. There is also an option in doing the same using Adapter module.

But all this should be carried out manually by replace function and there is no standard way of doing it.

Regards,

Prakash

Former Member
0 Kudos

Hi Prakash,

Glad to see you again, many thanks to all your help.

As to this question, you've mentioned "replace function", what indeed is this? In Mapping or in Adatper?

One more question : Anyway the message should go through the SOAP adapter, so does SOAP adapter support such formats?

Thanks

Luis

former_member206604
Active Contributor
0 Kudos

Hi,

I guess you need this &lt and &gt only in the messages right.. thats is only for the payload and not for the SOAP envelope, header, body etc.

<i>>>>As to this question, you've mentioned "replace function", what indeed is this? In Mapping or in Adatper?</i>

You can either use ABAP or Java mapping. In which you can use the replace function that is available in java or ABAP to convert <> into &lt and &gt.

The other way is to write a Adapter module suing Java and inside that you need to get the payload and then replace the <> using the replace function that is available in java.

regarging the replace function it is not the graphical mapping replace function.

<i>>>>One more question : Anyway the message should go through the SOAP adapter, so does SOAP adapter support such formats?</i>

If you go for adapter module you will not have this problem.

Regards,

Prakash

Answers (2)

Answers (2)

GabrielSagaya
Active Contributor
0 Kudos
Former Member
0 Kudos

Hi eXperts,

I've fixed the problem. Use an XSL and simply specify disable-output-escaping = 'no' and the output will be in &lt/&gt instead of </>.

Thanks

Luis