cancel
Showing results for 
Search instead for 
Did you mean: 

XLSX external library working fine in BAS but not working in Fiori Launchpad

tejaswikosanam
Explorer
0 Kudos
403

Hi, 

I am using xlsx.full.min.js file in a File upload project. The xlsx.full.min.js is included in a folder under webapp and referencing it correctly.

tejaswikosanam_0-1718304985561.png

When I run the file locally in SAP BAS it's working fine. But when I deployed and ran from Fiori Launchpad it's throwing error as XLSX.read is not a function.

tejaswikosanam_0-1718304501064.png

I tried  /* global XLSX:true */ at the top of the controller. But the issue still occurs.

 

Could you please suggest how do I resolve this issue.
View Entire Topic
Noel_Hendrikx
Active Contributor
0 Kudos

I'd suggest not to use a relative path, but the full namespace instead. The file path is rendered differently, check out the network tab for the 404 not found lib file how it is being rendered.

 

tejaswikosanam
Explorer
0 Kudos
Hi Noel, I have changed to full namespace but still it's not working. I checked Network tab but there the file is not visible at all. Not sure whether it's loading at all. I tried using sap.ui.loader.config. But still it's not working. Is there any other procedure I have to follow? In QA system it's working well. Do I need update anything like tooling modules or install xlsx through BAS commands?