cancel
Showing results for 
Search instead for 
Did you mean: 

XIProxy:INTERFACE_REGISTRATION_ERROR

syedayubahmed
Participant
0 Kudos
436

Hi Experts,

I am doing an Web service(SOAP) -->PI-->ABAP proxy Interface.(Synchronous Communication)

Completed Designing ,configuration , generated abap proxy in ecc and created WSDL file from sender Agreement in PI.

Testing WSDL file from SOAPUI test tool by creating an project and copying the URL

(http://host:50000/dir/wsdl?p=1_ec75cd9c5e5f319f932fac8cc8df608f_portTypeBindingService) , and promoting for username and pwd.

and even I have given User pwd at left side of panel.

When I test the I am getting an below error at right side panel.

<SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

  <SOAP:Body>

      <SOAP:Fault>

        <faultcode>SOAP:Server</faultcode>

        <faultstring>Server Error</faultstring>

        <detail>

            <s:SystemError xmlns:s="http://sap.com/xi/WebService/xi2.0">

              <context>XIAdapter</context>

              <code>ADAPTER.JAVA_EXCEPTION</code>

              <text>com.sap.engine.interfaces.messaging.api.exception.MessagingException: com.sap.engine.interfaces.messaging.api.exception.MessagingException: XIProxy:INTERFACE_REGISTRATION_ERROR:

    at com.sap.aii.adapter.soap.ejb.XISOAPAdapterBean.process(XISOAPAdapterBean.java:955)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:585)

    at com.sap.engine.services.ejb3.runtime.impl.RequestInvocationContext.proceedFinal(RequestInvocationContext.java:43)

    at com.sap.engine.services.ejb3.runtime.impl.AbstractInvocationContext.proceed(AbstractInvocationContext.java:166)

    at com.sap.engine.services.ejb3.runtime.impl.Interceptors_StatesTransition.invoke(Interceptors_StatesTransition.java:19)

Search lot of SDN blogs, no helpful solution.

Can anyone help me solving this problem.

Thanks in advance.

Accepted Solutions (0)

Answers (4)

Answers (4)

udo_martens
Active Contributor
0 Kudos

Hi,

          <s:SystemError xmlns:s="http://sap.com/xi/WebService/xi2.0">

              <context>XIAdapter</context>

              <code>ADAPTER.JAVA_EXCEPTION</code>

This part of your error message is very strange. Usually interface_registration_error comes in context with proxies. Did you call a java proxy??

Can you send screenshot of both channels, sender and receiver channel?

Regards,

Udo

syedayubahmed
Participant
0 Kudos

Hi UDO,

I am not using Java Proxy. using abap proxy.

My Sender SOAP Communication Channel :

My Receiver XI Communication Channel:

udo_martens
Active Contributor
0 Kudos

At least the protocoll is strange (XI2.0). This is only for systems less than 6.40 (but then you have type=receiver).

But what about monitoring? Do you see anything in SXMB_MONI? What about the SAP system? Do you get anything there?

syedayubahmed
Participant
0 Kudos

Hi UDO,

I am using PI 7.1 and ECC 6.0 EHP 4.

Yes, I can see error messages in sxmb_moni.

The error message as :

Earlier it was XI3.0 and change it to XI2.0.

baskar_gopalakrishnan2
Active Contributor
0 Kudos

>Earlier it was XI3.0 and change it to XI2.0.

It should be XI 3.0

You message shows that no implementing class registered for the interface ... That means make sure that proxy is regenerated based on the latest your service inbound interface. Make sure your proxy and implemented logic matches.

syedayubahmed
Participant
0 Kudos

Hi Baskar,

I tried with XI 3.0, and regenerated proxy with changing description, still getting same error :

<SAP:Stack>No implementing class registered for the interface (ABAP interface, request message SI_CreditCheck_Request, request message, namespace http://xyz.com)</SAP:Stack>

<SAP:Retry>N</SAP:Retry>

udo_martens
Active Contributor
0 Kudos

Ok,

looks like no corresponding proxy was generated. Go in SAP to SPROXY and check, if for exactly that interface with that namespace a proxy is generated.

Regards,

Udo

syedayubahmed
Participant
0 Kudos

Hi Udo,

When I am trying to regenerating the proxy , I am getting message as Proxy is up to date . No Changes necessary.. and it shows in green color.

nageshwar_reddy
Contributor
0 Kudos

Hi Ahmed,

Have you checked if configuration of the business system is correct? In SXMB_ADM->Integration Engine configurtion, the role of the business system should be Application System? Also check in SLD to see if everything looks good. You can also run SLDCHECK and ensure all the checks are good.

syedayubahmed
Participant
0 Kudos

Hi Reddy,

Thanks for inputs.

SLDCHECK is fine. everything is in green color and its open the SLD page also in browser.

I have check in PI -->sxmb_adm--> the role of business system is Integration Server.

And in ECC-->SXMB_adm --> the role of business system is Application System.

Former Member
0 Kudos

Hi Ahmed,

Please also try the following tests:

- Test the Abap Proxy on it's own using TCode SPROXY & the payload of your message.

- Test configuration from Integration Directory --> Sender Agreement & use payload

- Test it from Runtime Workbench using the payload.

Something is confusing me with your proxies that have been generated...I think the problem is with the way you have define your Service Interface in the ESR. you mentioned that it was a synchronous scenario but you have 2 proxies for request & response. You should only have one proxy with both the request & response structures in it. Maybe you can do a screen dump of your Inbound Service Interface?

EDIT: P.s. screen dump the outbound service interface too please.

Regards, Trevor

aashish_sinha
Active Contributor
0 Kudos

Hi Syed,

If you have changed anything in Data Type after generating proxy, you need to regenerate the proxy once again.

If after regenerating it doesn't work, try to recreate business system at R3 in SLD and test it.

Regards

Aashish Sinha

udo_martens
Active Contributor
0 Kudos

Hi,

Completed Designing ,configuration , generated abap proxy in ecc and created WSDL file from sender Agreement in PI.

Sounds good.

Testing WSDL file from SOAPUI test tool by creating an project and copying the URL

(http://host:50000/dir/wsdl?p=1_ec75cd9c5e5f319f932fac8cc8df608f_portTypeBindingService) , and promoting for username and pwd.

What? I think you created a wrong url. It should be like:

http://<PI host>:<port>/XISOAPAdapter/MessageServlet?channel=:<sender business system>:<soap sender channel>

Regards,

Udo

syedayubahmed
Participant
0 Kudos

Hi UDO,

I am using PI 7.1, as we have an option to create an WSDL file form sender agreement with out giving

http://<PI host>:<port>/XISOAPAdapter/MessageServlet?channel=:<sender business system>:<soap sender channel> the said URL.

In this way I have created WSDL : PI-->ID-->Tool-->Sender Agreement-->Display WSDl-->

I have copied the above URL and pasted in SOAPUI.

Thanks.

udo_martens
Active Contributor
0 Kudos

Hi,

which endpoint is displayed in soapUI? Does it match to the url scheme above?

Regards,

Udo

syedayubahmed
Participant
0 Kudos

Hi UDO,

Thanks for your interest and quick reply,

Below 2 endpoint are displaying :

http://host:50000/XISOAPAdapter/MessageServlet?senderParty=&senderService=BS_xyz_Legacy&receiverPart...; When I run with this URL I am getting Error in SOAPUI as :

<SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

   <SOAP:Body>

      <SOAP:Fault>

         <faultcode>SOAP:Server</faultcode>

         <faultstring>Server Error</faultstring>

         <detail>

            <s:SystemError xmlns:s="http://sap.com/xi/WebService/xi2.0">

               <context>XIAdapter</context>

               <code>ADAPTER.JAVA_EXCEPTION</code>

               <text>com.sap.engine.interfaces.messaging.api.exception.MessagingException: com.sap.engine.interfaces.messaging.api.exception.MessagingException: XIProxy:INTERFACE_REGISTRATION_ERROR:

    at com.sap.aii.adapter.soap.ejb.XISOAPAdapterBean.process(XISOAPAdapterBean.java:955)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:585)

    at com.sap.engine.services.ejb3.runtime.impl.RequestInvocationContext.proceedFinal(RequestInvocationContext.java:43)

    at com.sap.engine.services.ejb3.runtime.impl.AbstractInvocationContext.proceed(AbstractInvocationContext.java:166)

https://host:443/XISOAPAdapter/MessageServlet?senderParty=&senderService=BS_Adventis_Legacy&receiver...; When I run with this URL I am getting

Thanks for your feedback.

udo_martens
Active Contributor
0 Kudos

Ok,

i think one channel is wrong. What kind of channels did u use? It should be soap sender, xi adpater for abap proxy receiver.

Can you monitor the channels? Did you get any hint? Can you see anything in SXMB_MONI?

Regards,

Udo

baskar_gopalakrishnan2
Active Contributor
0 Kudos

The problem might be due to following reasons

PI side you might have completed the task. At ecc side make sure proxy is regenerated correctly and then the implementation coding logic for the proxy might have not finished yet. So you get interface registration error.

syedayubahmed
Participant
0 Kudos

Hi Baskar,

Thanks for quick reply.

At ECC side Proxy are generated without any errors and Issue. All are in green color my interface's.

I check with abper and I am getting proper sample response when we test the proxy code from test tool of sproxy.

Steps are : ECC-->sproxy-->double click the service interface-->Test(f8)-->Execute-->F8.

Thanks