cancel
Showing results for 
Search instead for 
Did you mean: 

XI to 2011 Issues

Former Member
0 Kudos
63

We previously used Crystal Reports XI and had no issues but after upgrading to 2011 we are having some ODBC issues with a few reports.  We can no longer use the SQL Server ODBC connection we were using previously and have to use the CR SQL Server Native Wire for old reports to work.  However, this connection won't work with reports that have stored procedures.  Is there a way to get Crystal Reports 2011 working with the old SQL Server ODBC connection that we used before?

We are running SQL Server 2005, if you need any more info just let me know.

Thanks.

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Would I need to install the new drivers on the SQL server as well?

abhilash_kumar
Active Contributor
0 Kudos

No, you need the drivers on the client machines if that's where the reports are being run from

-Abhilash

Former Member
0 Kudos

Hi Pi,

What is the version of the Operating System? If you are using 64-bit OS then create a new connection under

C:\Winsows\syswow64 and then see if it works.

What are the ODBC drivers you are using?

- Nrupal

Former Member
0 Kudos

It is 32 bit Windows 7.  The driver is SQL Server 6.01.7601.17514, sqlsrv32.dll, that is the old one we used with XI.

We are currently using CR SQL Server Native Wire Protocol ODBC Driver 6.0, crsqls24.dll.

Former Member
0 Kudos

Hi Pi,

Is there any error message? What is the complete version of CR 2011 and SQL Server?

- Nrupal

Former Member
0 Kudos

The errors we get when using the SQL Server driver in order:

SQL Server version:

Microsoft SQL Server 2005 - 9.00.5057.00 (Intel X86)   Mar 25 2011 13:50:04   Copyright (c) 1988-2005 Microsoft Corporation  Standard Edition on Windows NT 6.0 (Build 6002: Service Pack 2)

Crystal reports version: 14.0.2.364 RTM

abhilash_kumar
Active Contributor
0 Kudos

Hi Pi,

SQL Server 6.01.7601.17514 is not the right driver to be used with SQL Server 2005.

Crystal Reports needs the new SQLNCLI 10.0 driver to work with SQL Sever 2005 and 2008.

-Abhilash

Former Member
0 Kudos

I have done some testing with that driver and we still run into issues:

Any idea how to resolve this error?

abhilash_kumar
Active Contributor
0 Kudos

Hi Pi,

Could you try OLEDB instead?

-Abhilash

Former Member
0 Kudos

I have tried this as well but maybe I am doing it wrong.. Currently when I have tried to set this up I open the report, go to database expert, select OLD DB (ADO) and have been choosing Microsoft OLE DB Provider for SQL Server.  After entering info and it attempts to login I get:

abhilash_kumar
Active Contributor
0 Kudos

Hi Pi,

You're still using the old driver!

Go to OLEDB > scroll down to the bottom until you find SQL Server Native Client 10.0.

That's the one you need to use. Also, this makes me guess that you might have used the same old driver with the ODBC connection too?

-Abhilash

Former Member
0 Kudos

I was using the correct one with the ODBC, but I tried again with OLEDB and the new driver and get this now:

abhilash_kumar
Active Contributor
0 Kudos

That for some reason, looks like a SQL Server issue to me.

Does the ODBC connection test successfully?

-Abhilash

Former Member
0 Kudos

Yes, it will connect successfully when testing.