cancel
Showing results for 
Search instead for 
Did you mean: 

XI config problem - ABAP proxies

Former Member
0 Kudos
74

Hi all,

Previously our CRM development and quality system were both connected to the same XI system (development). Now we have added a XI quality system (SLD for both systems is identical = XI DEV) and we are switching the communication of the CRM QA to this new system.

Following actions have been performed:

ON CRM QA

1) Adjust integration engine of CRM QA in SLD sot that it points to

2) Adjust TCP/IP connection LCRSAPRFC so that it point to XI QA

3) Adjust integration engine via sxmb_adm so that it point to XI QA

4) Reactivate queues XBT*

ON XI QA

1) create correct connections in sm59

2) Reactivate queues XBT*

Then we tried the following minimal scenario: CRM --> XI --> SQL dbase

The configuration of the scenario in DEV and QA is identical.

When we check the sxmb_moni on both system, we can see the following.

Inbound message on CRM QA has the following data in his SOAP header (MAIN).

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

<!-- Inbound Message

-->

<SAP:Main xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsu="http://www.docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" versionMajor="003" versionMinor="000" SOAP:mustUnderstand="1" wsu:Id="wsuid-main-92ABE13F5C59AB7FE10000000A1551F7">

<SAP:MessageClass>ApplicationMessage</SAP:MessageClass>

<SAP:ProcessingMode>asynchronous</SAP:ProcessingMode>

<SAP:MessageId>459E68D8-4622-0AE7-E100-00000AE90961</SAP:MessageId>

<SAP:TimeSent>2007-01-05T17:00:39Z</SAP:TimeSent>

<b><SAP:Sender>

<SAP:Service>CQ5CLNT400</SAP:Service>

<SAP:Interface namespace="http://agfa.com/xi/HE/CRM/OG/Quotation/100">MI_BAPI_ONEORDERS_RESP_OB</SAP:Interface>

</SAP:Sender></b>

<SAP:Interface namespace="http://agfa.com/xi/HE/CRM/OG/Quotation/100">MI_BAPI_ONEORDERS_RESP_OB</SAP:Interface>

</SAP:Main>

The sender is filled in correctly with the entries service and interface.

If we now check the message entering on the XI QA system, we can see this.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

<!-- Inbound Message

-->

<SAP:Main xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsu="http://www.docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" versionMajor="003" versionMinor="000" SOAP:mustUnderstand="1" wsu:Id="wsuid-main-92ABE13F5C59AB7FE10000000A1551F7">

<SAP:MessageClass>ApplicationMessage</SAP:MessageClass>

<SAP:ProcessingMode>asynchronous</SAP:ProcessingMode>

<SAP:MessageId>459E68D8-4622-0AE7-E100-00000AE90961</SAP:MessageId>

<SAP:TimeSent>2007-01-05T17:00:39Z</SAP:TimeSent>

<b> <SAP:Sender>

<SAP:Service>CQ5CLNT400</SAP:Service>

<u> <SAP:Interface namespace="" /></u>

</SAP:Sender>

<u> <SAP:Receiver>

<SAP:Party agency="" scheme="" />

<SAP:Service />

<SAP:Interface namespace="http://agfa.com/xi/HE/CRM/OG/Quotation/100">MI_BAPI_ONEORDERS_RESP_OB</SAP:Interface>

<SAP:Mapping />

</SAP:Receiver></u></b>

<SAP:Interface namespace="http://agfa.com/xi/HE/CRM/OG/Quotation/100">MI_BAPI_ONEORDERS_RESP_OB</SAP:Interface>

</SAP:Main>

The sender namespace is empty AND the tag receiver is added, which contains the namespace value now. This is the message ENTERING the XI QA system, so normally this soap header information should be identical to the one we see in the CRM QA system.

If we check the SOAP Header data on XI DEV --> message processed when CRM QA and XI DEV were still connected we see that it is identical to the one on CRM QA.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

<!-- Inbound Message

-->

<SAP:Main xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsu="http://www.docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" versionMajor="003" versionMinor="000" SOAP:mustUnderstand="1" wsu:Id="wsuid-main-92ABE13F5C59AB7FE10000000A1551F7">

<SAP:MessageClass>ApplicationMessage</SAP:MessageClass>

<SAP:ProcessingMode>asynchronous</SAP:ProcessingMode>

<SAP:MessageId>459B66C3-7600-0AE4-E100-00000AE90961</SAP:MessageId>

<SAP:TimeSent>2007-01-04T15:32:00Z</SAP:TimeSent>

<b> <SAP:Sender>

<SAP:Service>CQ5CLNT400</SAP:Service>

<SAP:Interface namespace="http://agfa.com/xi/HE/CRM/OG/Quotation/100">MI_BAPI_ONEORDERS_RESP_OB</SAP:Interface>

</SAP:Sender></b>

<SAP:Interface namespace="http://agfa.com/xi/HE/CRM/OG/Quotation/100">MI_BAPI_ONEORDERS_RESP_OB</SAP:Interface>

</SAP:Main>

Because of the incorrect SOAP header data, the message isn't processed correctly on XI QA. Instead of executing the receiver identification step, it tries to call on inbound proxy ... .

This is some really weird behaveour and I don't know what could be wrong.

Can some-one please tell me what the missing link here is?

Kind regards!

Joris

Accepted Solutions (1)

Accepted Solutions (1)

stefan_grube
Active Contributor
0 Kudos

When you think, the message tries to call an inbound proxy in XI, you should check SXMB_ADM if the system is maintained as XI and not as application system.

Don't be worried about the interface namespace. In the XI message is no difference between sender interface and receiver interface. So it is suffifient, when it is mentioned once.

Regards

Stefan

Former Member
0 Kudos

That was indeed the problem Stefan!

Thanks a lot!

Kind regards

Joris

Answers (2)

Answers (2)

moorthy
Active Contributor
0 Kudos

Hi,

check out this-

/people/vijaya.kumari2/blog/2006/01/26/how-do-you-activate-abap-proxies

Also check the Queue are registered in the XI as well as R/3 box in the transaction SXMB_ADM

Regards,

Moorthy

STALANKI
Active Contributor
0 Kudos

Can u check the ABAP proxies section in the blog.https:///people/sravya.talanki2/blog/2006/12/27/aspirant-to-learn-sap-xiyou-won-the-jackpot-if-you-read-this-part-iii

You have info on everything in ABAP proxies and it is worth giving a reading!