cancel
Showing results for 
Search instead for 
Did you mean: 

Xcelcius Dashboard takes hrs to update

Former Member
0 Kudos

Xcelcius SP2

BO XIR3.1 Edge

Oracle 10g

I have a simple Xcelcius dashboard containing a QAAWS connected to an Oracle database.

When the data in the database updates, the data in the dashboard does not update....even when I refresh the data connection.

I have reproduced the same query in DeskI, and when I refresh the report, the data updates immediately; but in the dashboard it remains static and takes several hours to update.

Has anybody encountered this problem before?

View Entire Topic
Former Member
0 Kudos

Hello Joe,

An explanation might be that since XI 3.0, QaaWS uses a caching mechanism to improve performance when interacting with a dasboard.

When two identical requests are served within same session, data is served again from the cache (i.e. a hidden WebI document) instead of querying database for the same dataset again. Session duration is controlled with a timeout parameter you can tune for each QaaWS query. You can access the parameter from Advanced Parameters... command available on the query edition wizard first step, this opens a settings panel, default value for timeout parameter is 60 seconds.

If you need to disable caching, you can use servlet parameter qaaws.cache_dpresult.optim, and set :

qaaws.cache_dpresult.optim=false

into configuration file dsws.properties, this will disable caching for all QaaWS queries managed from corresponding servlet.

Do not forget to restart application server for that parameter to be taken into account.

Hope that helps,

David.

Former Member
0 Kudos

Thank you for your response. I changed the qaaws.cache_dpresult.optim to false on the dsws.properties file restarted the server but still the problem persists. Any other ideas?

Former Member
0 Kudos

Hi Joe,

I'll suggest, you execute the report with some condition so that less data will get downloaded.

Example, you can reduce the date range.

OR change your query in such a way that it would give you aggreegated data and not the detailed data.

Reducing number of rows in the report output would improve the performance.

Hope this helps.

Regards,

Rashmi