Showing results for 
Search instead for 
Did you mean: 

Wrong URL prefix for 'Execute in Browser...' from WAD

Former Member
0 Kudos


When I want to test a web template on our system from within the WAD, I get a wrong URL.

The serverspecification and the port is wrong.

It states http://em1ahp02.web.bc:8130/<rest of URL> where it should be http://sapbwbip.web.bc:8000/<rest of URL>.

The specification sapbwbip.web.bc is an alias for em1ahp02.bc. In RZ10 (instance profile) icm/host_name_full is set to sapbwbip.web.bc.

Where are the URL prefix settings for the WAD defined in the system?

Thanks for any helpful input.


Eric Van Grieken

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos


check note 805344 maybe it will be helpful



Former Member
0 Kudos

Problem is solved.

This is what happened:

We have following parameter setting:




What actually happens in the system is following:

If message server is active, the value for rdisp/mshost is taken. The domain from icm/host_name_full is appended to it as well as the value from ms/http_port_0 giving:


As we only had the IP alias sapbwbip.web.bc defined the address http://em1ahn03.web.bc:8310 resolved to nothing.

We had to add the IP alias em1ahn03.web.bc.

Now it works as supposed to be.

Active Contributor
0 Kudos

Hi Eric,

In SE37 run RSBB_URL_PREFIX_GET. This will return the URL generated by the system. You can check table TWPURLSVR too.

Hope this helps...