cancel
Showing results for 
Search instead for 
Did you mean: 

wrong , start x_server?

Former Member
0 Kudos
324

Start the x_server:

x_server start

it tells me:

Failed to get indep data work path:Section not in Registry:GlobalsIndepData [0:No system errortext for ERRNO 0]

why? thanks;

Accepted Solutions (0)

Answers (1)

Answers (1)

roland_mallmann
Advisor
Advisor
0 Kudos

Hi,

can you tell me if you've got the MaxDB registration file /etc/opt/sdb?

It should not only be there, but also filled with the relevant information.

Example /etc/opt/sdb:

[Globals]

IndepData=/sapdb/data

IndepPrograms=/sapdb/programs

SdbOwner=sdb

SdbGroup=sdba

Kind regards,

Roland

Former Member
0 Kudos

i create sdb at /etc/opt, like:

IndepData=/root/develop/maxdb7.6/DevData

IndepPrograms=

SdbOwner=sdb

SdbGroup=sdba

<indep_programs_path>: not used by the development

environment (because $SAPDB_NO_INDEPPATH is set)

in source.readme . so i can't set IndepPrograms.

a new error:

ERR 11937 XSERVER Create named pipe '/root/develop/maxdb7.6/DevData/fifo/xserver_localhost_logger' failed:No such file or directory

why?

roland_mallmann
Advisor
Advisor
0 Kudos

Hi,

it seems a couple of directories/folders are missing. Notably:

<IndepData>/config

<IndepData>/dbspeed

<IndepData>/diag

<IndepData>/fifo

<IndepData>/ipc

<IndepData>/pid

<IndepData>/ppid

<IndepData>/wrk

The database owner should have read + write permissions on all the above directories. On the 'ipc' directory, <b>all</b> users should have <b>all</b> permissions.

Regards,

Roland

Former Member
0 Kudos

thanks,

x_server started.

but , have any warning.

WNG 12457 XSERVER NI Init: Failed stat on niserver

WNG 12457 XSERVER NI Init: /root/develop/maxdb7.6/V76_00_10/MaxDB_DEV/usr/pgm/niserver

WNG 12457 XSERVER NI Init: No such file or directory

WNG 12457 XSERVER NI Init: Automatic niserver start failed

WNG 12456 XSERVER NISSL Init: Failed stat on nisslserver

WNG 12456 XSERVER NISSL Init: /root/develop/maxdb7.6/V76_00_10/MaxDB_DEV/usr/pgm/nisslserver

WNG 12456 XSERVER NISSL Init: No such file or directory

WNG 12456 XSERVER NISSL Init: Automatic nisslserver start failed

12902 XSERVER started, 'X32/LINUX 7.6.00 Build 010-000-000-000'

Former Member
0 Kudos

i ignore warning.

run " dbmcli -s -R $INSTROOT inst_reg -c

ERR -24994,ERR_RTE:runtime environment error1,

could not write to registry,error message:MKdir(Registry): Permission denied

my identity is root.

why permission denied?

Former Member
0 Kudos

help me! thanks

roland_mallmann
Advisor
Advisor
0 Kudos

Hi,

could you show me the output of the following command:

ls -la /root/develop/maxdb7.6/DevData

Kind regards,

Roland

Former Member
0 Kudos

root:

run ls -la /root/develop/maxdb7.6/DevData

total 80

drwxrwx--- 10 sdb sdba 4096 Jul 25 10:39 .

drwxr-xr-x 5 root root 4096 Jul 25 10:43 ..

drwxr-xr-x 2 root root 4096 Jul 25 10:37 config

drwxr-xr-x 2 root root 4096 Jul 12 09:47 dbspeed

drwxr-xr-x 2 root root 4096 Jul 12 09:48 diag

drwxr-xr-x 2 root root 4096 Jul 13 15:19 fifo

drwxr-xr-x 2 root root 4096 Jul 12 09:48 ipc

drwxr-xr-x 2 root root 4096 Jul 12 09:48 pid

drwxr-xr-x 2 root root 4096 Jul 12 09:48 ppid

drwxr-xr-x 2 root root 4096 Jul 25 10:39 wrk

roland_mallmann
Advisor
Advisor
0 Kudos

Hi,

that doesn't look like it's supposed to look.

The standard would look like:

Owner: <the user you entered in file /etc/opt/sdb>

Group: <the group you entered in file /etc/opt/sdb>

Please change this for all directories.

Additionally, the 'ipc' directory should be open for everyone (777 permissions).

Regards,

Roland