cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong Data

Former Member
0 Kudos
39

I am loading data from PSA to InfoObject.

In the Transfermation: the key = /bic/divsion & /bic/seg

PSA only contains 36 records and it says 36 get loaded. But when I checked the Master Data, it has 75 records.

It loads 36 records = (/bic/divsion & /bic/seg)

36 records = /bic/seg and

3 records = /bic/divsion

Why does this happen? Can anyone help? Thanks!

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

In teh P-table,you can almost of half of the records with OBJVERS = 'A' .And almost of half of the records with OBJVERS = 'M' .

So activate the Info object.And see the affect. Your doubt will be cleared.

With rgds,

Anil Kumar Sharma .P

Former Member
0 Kudos

Sorry, it still has the same wrong records.

Former Member
0 Kudos

Hi,

Sorry I mistyped there.

Right click on Info object and select <i>Activate master data</i>.

With rgds,

Anil Kumar Sharma .P

Former Member
0 Kudos

That was what I have done, but it didn't help in my case.

Former Member
0 Kudos

As a part of sanity check,

Does it have any records with version "M" in the master data table??

Try executing change run for that infoobject if there exist any such M records.

Hope it Helps

Chetan

@CP..

Former Member
0 Kudos

Hi CP:

How do I know what version is it? M or A. What does this mean? I know how to execut change run by using Process chain. Other places can I do it too?

Thanks!

Former Member
0 Kudos

Hi well if you go to tables (/bic/divsion & /bic/seg) individually ,you have the field

Version ,select "M" and execute to check if there are any entries.

You can do that using se16>/bic/divsion or RSD1>Infoobject>Tab- Master data>/bic/divsion>technical settings>entries

If there are entries execute Change Run using

RSA1>Tools>Apply Attr/Hierarchy run..hit execute Button.

Hope it Helps

Chetan

@CP..

Former Member
0 Kudos

in the AWB - menu (on the top) - tools - apply hierarchy/attribute change. You can do a ACR that way too.

Former Member
0 Kudos

You can also execute Attr/change run using

SE38-->RSDDS_AGGREGATES_MAINTAIN ...

Keep selections open...do not select anything if not aware of..

Hit execute button

Hope it Helps

Chetan

@CP..

Former Member
0 Kudos

In the table, OBJVERS = A for all records.

Former Member
0 Kudos

could be that some master data already existed and got added now.

try deleting the master data completely and then reload. give it a bash...

Hope it Helps

Chetan

@CP..

Former Member
0 Kudos

I deleted all the master data before. First, it said Not all master data can be deleted. Second time I clicked delete, it's all gone. It looks strange to me.

Let me explain more clear about what I have done:

I created 4 InfoObjects by using PROHIE as a reference:

DIVSN (4 records in PSA)

SEGMNT (36 records in PSA)

ERL (418 records)

SEQENCE (5377 records)

Data will get loaded from 4 PSAs to one InfoObject PROHIE. In the transfermation Rule, I used the following formulars as the keys:

DIVSN (DIVSN)

SEGMNT (DIVSN & SEGMNT)

ERL (DIVSN & SEGMNT & ERL)

SEQENCE ((DIVSN & SEGMNT & ERL & SEQENCE)

I found that it should load 5835 records but it acturally loaded 11535 records. I deleted all Master Data in PROHIE and only loaded DIVSN and SEGMNT for testing purpose. I saw:

SEGMNT loaded 36 records = (DIVSN & SEGMNT)

36 records = SEGMNT and

3 records = DIVSN

Former Member
0 Kudos

How can I delete MasterData completly?

Former Member
0 Kudos

I found out if I change the following attributes from NAV to Display attributes. It loaded correctly. But why is that?

DIVSN

SEGMNT

ERL

SEQENCE

Former Member
0 Kudos

not sure excatly how it solved the issue..

However for deleting the data follow below guidelines

For deleting any master data

Need to delete first where its referenced to ,so check the where used list for the infoobject and delete the places where that master data is referenced

Typically - Attributes,Hierarchies,Texts,Transaction data,in Query - Hardcoded master data

Lots of ways around ,even using database utility ;however that leads to inconsistencies and requires sounds knowledge so wont advocate those steps.

You can follow below steps -

R-Click Delete master data ,it wont delete all if its referenced,so now go to

Tcode - SLG1

Object = RSDMD

Subobject = MD_DEL

Hit execute button

it will fetch you the log showing all the places(references) where you need to delete the data in order to delete the actual master data.

After deleting the data from referenced places you can completely delete the master data.

Hope it Helps

Chetan

@CP..

Former Member
0 Kudos

Thank you!

Former Member
0 Kudos

welcome..no probs

Have a Nice day..

Chetan

@CP..

Former Member
0 Kudos

When I execute Tcode SLGL, it says Transaction does not exist??

Former Member
0 Kudos

Its SLG1 .

Hope it Helps

Chetan

@CP..

Answers (0)