cancel
Showing results for 
Search instead for 
Did you mean: 

Workset Map iView does not work with custom role

Former Member
0 Kudos
61

Hi there,

I have a custom role, created with SRM iViews. Within this role there is a workset map iView. I adapted the "Relative Workset Location" (levelsup etc.) to the correct values.

I know that the values are correct because in SAP Light Framework, the workset map works and shows the correct overview. But when I change to the SAP standard framework (not light), then I get the error "Could not find workset location. Check the 'Relative Workset Location' parameter of this iView."

The SAP standard SRM role works with both frameworks.

So:

1) There must be a difference between the SAP standard role and my custom role. What might it be? Any idea?

2) The difference between light framework and standard framework is, that navigation in light framework works with the request parameter "NavigationTarget". So I assume that when the parameter "NavigationTarget" is not set, the start point for the workset iView might not be found within custom role.

Did anyone have the same problem or any ideas?

Thanks a lot in advance for your help.

Best Regards

Joschi

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Joschi ,

Have you tried creating a structure (for your custom role) which is similar to the standard role with either of the framework page . I hope you have tried replicating the same structure/heirarchy with your custom role .

Also try this once and see if it helps . Under your role place the worksetmap iview and create a folder(at second postion) . Under this folder again place worksetmap iview (first position) and then place the remaining iviews . Put the value levelsup=1 in both the worksetmap iviews .

Regards

Mayank

Answers (0)