cancel
Showing results for 
Search instead for 
Did you mean: 

Workflows getting triggered automatically by system

former_member197703
Participant
0 Kudos

Hi Experts,

We have a customized workflow which is triggered using a custom program (Custom Event).

From last 3 days system is triggering the workflow automatically

and the workflow is triggered every half an hour from 12 AM till 9 AM only.

These workflow instances are for the same business object key value.

On last Thursday at around 5 PM, workflow was launched manually by a user

and from friday midnight system is trying to launch the workflow automatically for the same Business Object Key value.

When i saw the logs of the workflow triggered manually by user,

there is a comment that 'Start Event Received',

But in the logs related to all other workflow instances which are created autoatically by the system,

there is no comment that ' Start Event Received' .

Please advice, these workflow instances should not be triggered automatically.

Version: ECC 5.0

Regards,

Vargi

Accepted Solutions (0)

Answers (2)

Answers (2)

former_member185167
Active Contributor
0 Kudos

Hello,

If you can't find it via SM37 then you may want to try doing a where-used on the function modules

SAP_WAPI_START_WORKFLOW and SWW_WI_START, looking especially for custom programs.

regards

Rick Bakker

Hanabi Technology

former_member197703
Participant
0 Kudos

Hi Rick,

There is no custom program which is using these FM's.

Also i haven't found any job which is running between 12 AM to 9 AM, specific to this issue.

This ia a Material Master workflow, which is used to create Material views based on Material Plant combination.

Regards,

Vargi

former_member185167
Active Contributor
0 Kudos

Hello,

Maybe it's a job that's running in SM37 all the time, but checks the time before triggering the workflow.

I can't think of any (likely) way it could be scheduled every half hour, except perhaps if each workflow instance is calling the next, but I assume that would be easy to find if you looked at how the workflow works.

Check every job in SM37, starting with those scheduled every 30 mins.

regards

Rick Bakker

Hanabi Technology

former_member197703
Participant
0 Kudos

Hi Rick,

Thanks for your help.

Actually there was 2 tRFC entries in error state and causing the workflow to be triggered automatically.

I have removed those entries and now the issue is resolved.

Thanks,

Vargi

former_member185167
Active Contributor
0 Kudos

Hello,

Interesting! Can you tell me more about these tRFC entries?

Where were they, how did you find them, what caused it?

regards

Rick Bakker

Hanabi Technology

former_member197703
Participant
0 Kudos

Hi Rick,

I found those entries in SM58, both the entries were in error state.

I check with basis team and we thought that by deleting these entries might solve our problem and it did resolve our issue.

I am still not able to found the cause for these tRFC error entries. Thanks for all your help.

Regards,

Vargi

former_member185167
Active Contributor
0 Kudos

Hello,

If I understand this correctly, you have a custom workflow which is being triggered automatically every 30 mins (midnight to 9am), and this should not be happening.

The fact that it doesn't say 'Start Event Received' most probably means it's being started via a function module (like SAP_WAPI_START_WORKFLOW).

You should check tx SM37 to see which jobs were running during the night and stopping at 9AM.

When you have that, look further in SM37 to see when the job first ran.

What does this workflow do?

regards

Rick Bakker

Hanabi Technology