Showing results for 
Search instead for 
Did you mean: 

Workflow Permission on new repository manager

Former Member
0 Kudos

Hi all,

I’ve customized a folder command “workflow inheritance” that applies the approval workflow to the subfolders. It is working properly on the ‘/documents’ repository.

The problem occurs when I tried to execute the same folder command on the repository that I’ve created ‘/myRepository’. The error, which is showed above, informs that I do not have required permissions. But, I’m logged in with administrator privileges.

The repositories both ‘/myRepository’ and ‘/documents’ have the same configurations. The only differences between them it is that the ‘/myRepository’ is a FileSystem Repository.

<b>Is there some workflow permission that is missing to ‘myRepository’ ?</b>


Access Denied
"/myRepository/Alcides Flach/Workflow test"
The item you are attempting to access requires permissions you do not have. Contact the item's owner or a system administrator to acquire the permissions in question.


Any help will be appreciated,

Alcides Flach

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Patricio and Eric,

Thank you for your help.

I make a mistake. I had to correct that my repository is CM-Repository and not a FileSystem Repository. I realized it when the Patricio said that on FileSystem repository some functionality are not supported.

When I tried to test my command in another CM-repository, as suggested by Eric, it’s works properly. Then, I remember that the ACL permissions were applied in my first repository.

The error that I was facing it is a development problem. Into the code, I was not using the permissions from the current user. For that reason my user with Administrator privileges was not working.

Best Regards,

Alcides Flach

Former Member
0 Kudos

Hi Alcides,

In this new repository, have you added statemngt and svc_acl services ? after that you must restart the server.

Remember: the status management service requires the service ACL service and the application property service.

In the file system repository manager:

The following functions are not supported:

· Locking documents

· Creating links

· Using predefined properties

· Versioning


0 Kudos


I suggest to create a new CM-repository instead of a Filesystem repository with the same repository services as "/documents" and try it again.

As documented in the help:

"Depending on the type of repository manager, you cannot use some Knowledge Management functions." (

Hope it helps.