cancel
Showing results for 
Search instead for 
Did you mean: 

Workflow Not triggering

Former Member
0 Kudos
424

Hi All,

I have created a custom workflow for PR release.

i have activated the event linkage and the workflow is in active status.

But even then the workflow is not getting triggered whenever a PR is created.

Can anyone tell me what could be the possible cause of workflow not being triggered?

Thanks and regards,

Raj

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Raj - you have not said (or I have missed) whether the event you are expecting is actually occurring. As some of the folks have mentioned, go to txn swels and turn on the trace. Then perform your steps in txn me51n. Go back and turn off the trace. Now display the trace in txn swel. Did your event(s) appear?

(a) If so, it will show there in swel and additionally will show whether anything (i.e. your wf) received it. Note if event shows but no reciever, yet your linkage is fine (as you mentioned) in txn swetypv, then the only thing I can think of is you have a filtered start condition (txn swb_cond) where it decides to not trigger wf. If the wf is actually being executed then ensure the proper path within the definition is being followed (e.g. is not exiting on a decision step).

(b) if not, then either your event is not being raised via txn me51n (probably a functional config issue), or the event is queued (see txn sweqadmin).

Please report back as we all would like to know the status.

Regards,

Keith

former_member184495
Active Contributor
0 Kudos

Hi PK,

Hoping the Release Strategy is in place.

ur PR is item level or Overall Release.

If item level BOR is BUS2009 and event is ReleaseStepCreated.

If its Overall PR BOR is BUS2105 and event is ReleaseStepCreated.

Hope it helps.

Aditya

Edited by: Aditya Varrier on Jul 15, 2008 5:25 PM

Former Member
0 Kudos

Hi,

I am using bus2105 for overall release.

When i test it manually the workflow is working fine.

But it is not triggering whenever i create a PR using transaction code ME51n.

Can you tell me why this could be happening??

Former Member
0 Kudos

hi Raj,

In general PR workflows r set to release strategy. Plz confirm with ur MM consultant whether a release strategy has been set in SPRO. If the SPRO settings r proparly done then see if u have activated the workflow and now check in SWELS.

Regards,

Dheepak

Former Member
0 Kudos

Hi,

I think you can use BUS2009 object and RELEASESTEPCREATED event.

Best regards!

Kleber