cancel
Showing results for 
Search instead for 
Did you mean: 

Workflow Log and Details empty

Former Member
0 Kudos

Dear all,

we're facing a problem and are beeing not able to solve it.

I also attached 3 jpg, hope they'll help to show the issue.

So, in some workflows the workflow log completely empty. There are neither task nor details show. Please have a look on attachement "1.png".

This is the first issue.

After pressing "Refresh" the "Workflow and task" appear (see "2.png"). Okay so far.

But now the user want to see the details of a task. Therfore he may click on the "details button" behind the task description (see 3.png). And nothing will be shown in the details window below.

This error appears now and then. In addition the user has all necessary rights. In case of such faulty workflow no user is able to see the details, not even a with sapall rights. But for some reasons, this error appears. We don't know how to determine the error.

I would be grateful if someone could help!

BR
Mathias

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Can you open the technical workflow log? Are you able to see the step details/history there?

Could be some bug (find OSS note) or as Rob said it could be a problem with the SAP Logon (try to update it).

Regards,

Karri

Former Member
0 Kudos

Hi, it's the same on the technical view.

In addition I just tried SAP logon 7.20 and 7.30. It's the same...

former_member186746
Active Contributor
0 Kudos

Hi Mathias,

Your next step is to find out if the tables are correct with the workflow log data.

Tables SWWWIHEAD, SWPSTEPLOG or execute a SAP_WAPI function module to retrieve data.

If it is safe to say that log data is present but incorrectly shown and there are no SAP notes on this subject then you should raise an oss message.

Kind regards, Rob Dielemans

former_member185167
Active Contributor
0 Kudos

Hello,

"After pressing "Refresh" the "Workflow and task" appear"


This would indicate that the data is in the table but it's some sort of buffering problem.

Maybe BASIS can help here. Are any other parts of the system having a  problem?

Always worth trying SWU_OBUF.

regards

Rick Bakker

former_member185540
Active Participant
0 Kudos

HI,

Try the following:  clear buffers with swu_obuf

Then use the technical view, you need to change that in the personal settings. If you still cant see the log then you need a system trace.

Thanks,

Andy

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi all,

thanks a lot for your help! I really appreciate this!

I seems, that the Log History has just deleted from table SWWLOGHIST probably by using the SWWH transaction.

Well, now we have to check the permissions in order to prevent that anybody without permission do that...

Again thanks for your help! I learned a lot here!

BR
Mathias

former_member186746
Active Contributor
0 Kudos

You're welcome.

Also add transaction SWWL in your research to prevent people misusing that transaction (also check the job logs I once encountered a basis team that just scheduled swwl because they thought that the tables were getting too big and instead of archiving they decided to delete it which is insane since it is business data and you can fail an audit if those kind of data is missing in production).

Kind regards, Rob Dielemans

I042439
Employee
Employee
0 Kudos

Hi Mathias

See if the following note helps

1127850  - Workflow log: List does not contain any data            


regards,

Modak

former_member186746
Active Contributor
0 Kudos

Hi,

check the sap logon level. And search on the sap marketplace if any problems exist for the workflow log.

Other than that I have no idea what the cause could be.

If you don't find any answer then you should raise an OSS message to SAP.

Kind regards, Rob Dielemans