cancel
Showing results for 
Search instead for 
Did you mean: 

WIS 10006 error: object does not exist in report...

Former Member
0 Kudos

Hello All,

I've been having trouble with this particular formula that i'm using as a variable for parent-child report linking:

 ="<a href=\"../../opendoc/openDocument.jsp?iDocID=AVMeLBMmFrdJkNpCFp33vjs&sDocName=Open+Incident+Details+Report+-+Owning+Group&sIDType=CUID&sType=wid&sWindow=Same&lsSDateOpened-YearMonth="+[Date Opened - YearMonth]+"&lsSResolutionTimeCategorization="+[Resolution Time Categorization]+"&lsSOpCatTier1="+[Op Cat Tier 1]+"&lsSOwningGroup="+[Ticket Owner]+"\"target=\"_blank\">"+""+[Ticket Count]+"</a>"

The object in question is [Op Cat Tier 1]. This object is in query filter of the child report. All the other values pass from the parent to child report w/o issues but as soon as I add [Op Cat Tier 1], the error message appears:

The object '[Op Cat Tier 1]' at position 302 does not exist in the report. (Error: WIS 10006).

I've tried passing the value using both &lsS and &lsM and using 'in list' or 'equal to' in the child report. I've been struggling at this for a while. Any ideas?

Thanks,

Carter

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Alan,

Yes the [Op Cat Tier 1] object is in the parent report, and in the child report as well.

Former Member
0 Kudos

When do you get the issue? Is it when you refresh the Parent report or when you click on the link to go to the child?

Also assuming it is when you click on the link, try hard coding the value for instance

"&lsOpCatTier1=Test"

If this works then the problem is with the parent not the child.

Regards

Alan

Answers (3)

Answers (3)

Former Member
0 Kudos

Okay....I figured it out. I didn't have the Op Cat Tier 1 object in the parent's 'Result Object' panel.....

the code validates correctly now.

Former Member
0 Kudos

Hi Alan,

I get the error message when I try to validate the the code in the Variable Editor. I use a variable to hold the hyperlink instead of pasting the code directly into the report.....

So we are getting somewhere....when I used the '&lsSOpCatTier1=Test", the code validates successfully.....

Former Member
0 Kudos

Hi Carter,

Is the

[Op Cat Tier 1]

in the Parent report?

Regards

Alan