cancel
Showing results for 
Search instead for 
Did you mean: 

Why are we receiving eclipse start up errors?

Former Member
0 Kudos
198

We have used neon and have added the cloud platform addins as instructed in the following link.

https://www.sap.com/developer/tutorials/hcp-java-eclipse-setup.html.

But, when we restart eclipse we always get this first error message followed by a series of messages afterwards. I haven't pasted all of them as it appears this is the primary erro leading to the subsequent ones. Any insight anyone can provide as to what we have possibly done wrong would be appreciated.

!ENTRY com.sap.it.ide.rt.profiles 4 0 2017-07-30 18:07:42.959 !MESSAGE java.lang.IllegalStateException: BackendCommandDispatcherFactory was not created in UI Thread or no display created yet! !STACK 0 com.google.common.util.concurrent.UncheckedExecutionException: java.lang.IllegalStateException: BackendCommandDispatcherFactory was not created in UI Thread or no display created yet! at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2199) at com.google.common.cache.LocalCache.get(LocalCache.java:3932) at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3936) at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:4806) at com.sap.it.ide.rt.profiles.actions.CapabilityProviderImpl.getActiveCapabilities(CapabilityProviderImpl.java:426) at com.sap.it.rtprofile.api.metadata.impl.BaseProfileImpl.getCapabilities(BaseProfileImpl.java:55) at com.sap.it.product.profile.impl.ProductProfileManagerImpl.registerProfile(ProductProfileManagerImpl.java:70) at com.sap.it.product.profile.impl.ProductProfileManagerImpl.updateProfile(ProductProfileManagerImpl.java:228) at com.sap.it.ide.rt.profiles.actions.MetadataHandler.registerRemoteCMDDirectory(MetadataHandler.java:169) at com.sap.it.ide.rt.profiles.actions.MetadataHandler.loadCMDFiles(MetadataHandler.java:55) at com.sap.it.ide.rt.profiles.actions.RuntimeProfilesFetcher.earlyStartup(RuntimeProfilesFetcher.java:789) at org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup(EarlyStartupRunnable.java:77) at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:53) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.ui.internal.Workbench$55.run(Workbench.java:2835) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55) Caused by: java.lang.IllegalStateException: BackendCommandDispatcherFactory was not created in UI Thread or no display created yet! at com.sap.it.commons.command.eclipsechannel.backend.impl.BackendCommandDispatcherFactoryImpl.<init>(BackendCommandDispatcherFactoryImpl.java:62) at com.sap.it.commons.command.eclipsechannel.backend.impl.BackendCommandDispatcherFactoryImpl.<init>(BackendCommandDispatcherFactoryImpl.java:53) at com.sap.it.commons.command.eclipsechannel.BackendCommandDispatcherFactoryProvider.createInstanceIfNecessary(BackendCommandDispatcherFactoryProvider.java:64) at com.sap.it.commons.command.eclipsechannel.BackendCommandDispatcherFactoryProvider.grantBackendCommandDispatcherFactory(BackendCommandDispatcherFactoryProvider.java:56) at com.sap.it.ide.rt.profiles.actions.CapabilityProviderImpl$1.load(CapabilityProviderImpl.java:94) at com.sap.it.ide.rt.profiles.actions.CapabilityProviderImpl$1.load(CapabilityProviderImpl.java:1) at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3522) at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2315) at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2278) at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2193) ... 15 more

Accepted Solutions (0)

Answers (2)

Answers (2)

Sharathmg
Active Contributor
0 Kudos

Eclipse Kepler works fine for me. Re-install eclipse. Also, check the Java paths, which normally cause issue.

Reinstall the plugins for UI5, if necessary.

Regards,
Sharath

former_member197689
Active Participant
0 Kudos

Hi James,

I just tested on a new Windows image. The installation went well with out any issues.

Please download Eclipse Neo and try again.

Thanks,

Jin