cancel
Showing results for 
Search instead for 
Did you mean: 

Where have my External Libraries gone!?

Former Member
0 Kudos

As far as I can tell I've jumped through all the hoops for creating and adding External Jars as a J2EE Server Component to my DC project. The Jars appear in in the project properties. I have deployed and tested the project locally and it's fine. However, when I build the DC project, the jars are not added to the WAR hence I get class not found errors.

I sure there's probably one little checkbox I'm missing - I just wish I could find it. Can anyone help?

Accepted Solutions (1)

Accepted Solutions (1)

sid-desh
Advisor
Advisor
0 Kudos

Hi Craig,

If i have understood you correctly you have created an External Library DC, added some jars to it and wrapped that external library DC in a J2EE Library DC which you are using in a Web Module DC.

In this case i believe the jars will not be a part of the war file. They will be a part of the sda file generated by building the J2EE Library DC.

You will just use public part of external library dc in the web application for building the web application.

Please do let me know if i have understood you correctly.

Regards

Sidharth

Former Member
0 Kudos

Hi Sidarth,

That makes sense. Thanks for that. I still have the problem however, that the program cannot find the JCO jar. I have started the whole thing again following Valery Silaev's blog step by step one more time. What I have discovered is that the J2EE component Library is not deploying to the server. I get no error messages, it just doesn't appear in the Visual Administrator or the file system. The system has worked perfectly well in the past for other J2EE deployment projects (EAR deployment) but it seems it has a problem with J2EE library components.

Any ideas?

Craig

sid-desh
Advisor
Advisor
0 Kudos

Hi Craig,

What version of NWDS are you using. The problem maybe because the jar file is not being shown in the sda file of J2EE Library.

This problem has been discussed extensively in this forum. You will have to search for Marc Wirth's posts and you will find he has suggested a workaround for this.

However i must first ask are you developing Local DC's because the problem i have described above and the workaround only works for Local DC's. For other DC's there is a totally different solution.

Let us know your scenario.

Thanks and Regards

Sidharth

Former Member
0 Kudos

Hi Sidharth,

NWDS version is 7.0.0.6 build 200601142119. I created the DCs as local DCs to start with. I then checked them in and tried again, but this made no difference.

Thanks,

Craig

sid-desh
Advisor
Advisor
0 Kudos

Hi Craig,

I request you to go these two discussions. They have discussed the problem of jar not getting included very extensively and also the solutions.

Hope this is some help.

Regards

Sidharth

Answers (1)

Answers (1)

Former Member
0 Kudos

Check steps 1 and 2 of <a href="/people/valery.silaev/blog/2005/09/14/a-bit-of-impractical-scripting-for-web-dynpro">this weblog</a>.