Showing results for 
Search instead for 
Did you mean: 

Websphere MQ in netweaver

Former Member
0 Kudos


trying to integrate Websphere MQ into netweaver i do encounter some problems. though i followed this very precise reply

it still doesn't quite work for me. i guess i'm missing some configuration issues, as my factory-type property for example is "unknown". shouldn't the type be specified? and when, how to do that (i tried to specify the type in the xml but it remains unknown)? well, afterall i allways get the following error when trying to start the Connector:

Invalid factory: IBM_Queue_Factory ->

i really appreciate any hint,

thanks patrick

Accepted Solutions (1)

Accepted Solutions (1)

Product and Topic Expert
Product and Topic Expert
0 Kudos


information how to configure the registered factories on the J2EE Engine can be found here:

"JMS Administration"

Greetings, Jordan

Former Member
0 Kudos

hi jordan,

thanks for the help, but i my problems are not regarding setting up a connection-factory, its rather that its not referenced in the JMS-Connector General tab but rather being labeled as "unknown". in addition it works on the first try, but when doing a server-reboot its being reset to "unknown", though before the factory-type had been displayed as type of XAQueueConnectionFactory, which would be correct.

further i get a class-not-found exception javax/jms/JMSException, so i guess its also a classloading problem, as the jms.jar is not custom-jms-lib (as stated in the sap-help) but should still be available to a classloader up the hierarchie.

thanks patrick

update on progress:

though i'm not sure if its really a progress but at least i'm getting a new exception!

when deploying my mdb-app i get ->



whats really giving me the creeps is the sap-help provided, it doesn't state clearly whats required, how its supposed to be done in an understandable manner.

i'm sad :'(

Message was edited by: patrick kunert

Former Member
0 Kudos


the problem wasn't related to the factory neither to the destination configuration, it was a jms-libraries problem.

deploying the extensions via the va is the problem, it just doesn't seem to work right. deploying the jars as j2ee-server-component library was the solution as now everything works just fine!!!

should have tried that much much earlier.

i'm happy (big grin)


Answers (0)