cancel
Showing results for 
Search instead for 
Did you mean: 

WebIDE not working

former_member658382
Discoverer
0 Kudos

Due to some centrify and AD issue, the <SID>xsa and sap<SID>xsa users were deleted from the HANA server. After creating them, and changing back a number of file system owners under /hana/shared/SID/xs/controller_data/fss , web ide is not starting up. All other xsa apps like cockpit are working fine. Attached is the webide recent logs:

Connected, dumping recent logs for app "webide" 1/30/20 3:32:17.268 PM [API] OUT Starting instance [state STARTING, index 3] of droplet [id 8] of app 'webide' [Org 'DUKE', Space 'SAP'] at [lcdcenhanad01:50112]. 1/30/20 3:32:21.491 PM [APP/8-3] SYS #2.0#2020 01 30 15:32:21:487#-05:00#INFO#/approuter################PLAIN##Application router version 5.2.1# 1/30/20 3:32:21.493 PM [APP/8-3] SYS #2.0#2020 01 30 15:32:21:493#-05:00#INFO#/Configuration################PLAIN##Using empty destinations to run# 1/30/20 3:32:21.498 PM [APP/8-3] SYS #2.0#2020 01 30 15:32:21:498#-05:00#INFO#/Destination service################PLAIN##Looking for the missing environment destinations metadata: devx-ui5,di-core,xs-endpoint in destination service# 1/30/20 3:32:21.498 PM [APP/8-3] SYS #2.0#2020 01 30 15:32:21:498#-05:00#ERROR#/token-utils################PLAIN##can't get access token to the destination service : [Error: Error reading credentials for destination service. Please verify service is bound. VError: Found 0 matching services]# 1/30/20 3:32:21.499 PM [APP/8-3] SYS #2.0#2020 01 30 15:32:21:499#-05:00#ERROR#/Destination service################PLAIN##missing access token for destination service# 1/30/20 3:32:21.502 PM [APP/8-3] ERR 1/30/20 3:32:21.503 PM [APP/8-3] ERR /hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/lib/utils/JsonValidator.js:30 1/30/20 3:32:21.503 PM [APP/8-3] ERR throw new VError('%s%s: %s', 1/30/20 3:32:21.503 PM [APP/8-3] ERR ^ 1/30/20 3:32:21.503 PM [APP/8-3] ERR VError: xs-app.json/routes/0: Format validation failed (Route references unknown destination "devx-ui5") 1/30/20 3:32:21.503 PM [APP/8-3] ERR at JsonValidator.validate (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/lib/utils/JsonValidator.js:30:11) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Object.validateXsApp (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/lib/configuration/validators.js:126:15) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Object.exports.loadConfiguration (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/lib/configuration/app-config.js:25:14) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Object.module.exports.load (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/lib/configuration.js:19:34) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at bootstrap (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/lib/bootstrap.js:49:36) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Approuter.start (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/approuter.js:67:13) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Object.<anonymous> (/hana/shared/DE1/xs/app_working/lcdcenhanad01/executionroot/1a713bb7-6ffb-485a-996b-314ca36ceab2/app/node_modules/@sap/approuter/approuter.js:144:6) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Module._compile (internal/modules/cjs/loader.js:701:30) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10) 1/30/20 3:32:21.503 PM [APP/8-3] ERR at Module.load (internal/modules/cjs/loader.js:600:32) 1/30/20 3:32:38.437 PM [API] OUT Cleared instance [state CRASHED, index 0] of droplet [id 8] of app 'webide' [Org 'DUKE', Space 'SAP'] at [lcdcenhanad01:50089, pid 54706]. 1/30/20 3:32:38.444 PM [API] ERR Number of running instances for app 'webide' [Org 'DUKE', Space 'SAP'] is 0 but should be 1. Trying to adapt number of running instances... 1/30/20 3:32:38.543 PM [API] OUT Starting instance [state STARTING, index 0] of droplet [id 8] of app 'webide' [Org 'DUKE', Space 'SAP'] at [lcdcenhanad01:50115].

Any idea how this can be resolved?

Thanks!

Accepted Solutions (0)

Answers (1)

Answers (1)

vinita_kasliwal
Active Contributor
0 Kudos

Hi NIsha

Did you try this ?

xs restart webide

xs restart di-builder

Is this a trial or actual version?

Did you change the IP address on the host file?

Sometimes after an upgrade it does take time for Webide to start does it not start at all?

Did you get these logs from server and is there any error number like 503 etc on the screen?

https://answers.sap.com/questions/309284/sap-web-ide-503-service-not-available.html

Try this guide it has a lot of options which may be useful

https://help.sap.com/doc/2e94f735a0884e139100f02a13fc6510/SAPWEBIDE4HANA/en-US/InstallationTroublesh...

Regards

Vinita

former_member658382
Discoverer
0 Kudos

Hi Vinita,

Thank you for the suggestions. I did try restarting single apps like webide and di-builder. This is not a trial version but a development system. The IP address has not changed. Only the de1xsa and sapde1xsa users were deleted and some of the file system permissions had to be changed manually. I did try waiting for a while to see if the webide starts up but i still get the same error.

Nisha