cancel
Showing results for 
Search instead for 
Did you mean: 

WebIDE, index.html and white blank page problem

Former Member
0 Kudos

Hi all,

Please don't be too harsh on me for asking this as I am only starting my development journey

I created an app with WebIDE as a hybrid package, downloaded it, added mobile libraries and now I want to package it for Phonegap or other native app wrapper. The app works fine in a browser when I call the URL created by HCP. But when I try to start index.html it comes as white blank page. The same happens when I create a mobile app in Phonegap. There is no error and the app is not trying to connect anywhere, there is just white blank page.

I have read a few threads here and I am still lost. I am not sure if my index.html file needs to contain anything specific? I am also not sure whether it can be under "webapp" folder (as WebIDE places it). The folder question applies to libraries too, should I put the \resources folder in the main directory or in "webapp" folder? When WebIDE project is created the file structure looks as follows:

If you could point a newbie to the right place I would really appreciate it.

Thanks,

Mark

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

I think it may be useful if I attach my index.html file for reference. Here it is:

jamie_cawley
Advisor
Advisor
0 Kudos

Check out the Hybrid Application Toolkit which will configure and builds these apps for you.  For more info see

Regards,

Jamie

SAP - Technology RIG

Former Member
0 Kudos

Thanks Jamie. I know about HAT but I'm using Win7 and this tool doesn't support it.

I am still hopeful that WebIDE was built to support more than just HAT and I can move my files somehow to make it work.

jamie_cawley
Advisor
Advisor
0 Kudos

HAT will run on windows.  You can find the install instructions at

SAP Web IDE Hybrid App Toolkit Add-on

Regards,

Jamie

SAP - Technology RIG