cancel
Showing results for 
Search instead for 
Did you mean: 

WEBIDE code completion not working because of Project settings SAPUI5 version error ?

Momen_Allouh
Advisor
Advisor
0 Kudos
1,260

I have the latest SAP WEBIDE version and I have issue with code completion (it stopped working) as this screen shot:

When I checked the app "Project Settings" to see the SAPUI5 version for the app then I found the following error:

I keep selecting the latest version and saving but it is not saving because when I chevck again I still get the above error:

I am 90% sure the code completion not working because of the "Project Settings" issue.


I also checked the mainfest.json file of my project and the sap.ui5 setting looks correct:

Any help please ? I am facing this issue with many projects .

And it is so weird that WebIDE says "Project Settings Saved" but the error show up again when selecting the ui5 version!



Accepted Solutions (1)

Accepted Solutions (1)

Momen_Allouh
Advisor
Advisor

Oh i see, in my neo-app.json I added a new destination for oData but that not the issue. After checking again many times I found the issue was because I changed the path for the SAPUI5 Resources destination since the app will be deployed to ABAP system so I wanted to keep the resources link in index.html to what is in the ABAP sys so I changed the destination in the neo-app.json

from:

To:

When I changed it back to original default case "/resources" then project settings for SAPUI5 save fine and no error then the code completion starts to work.

Since I am changing only the "path" and not the "target/entryPath" of the destination then it should not affect the project settings (that stopped the code completion) since the app runs fine when I run from WEBIDE !

Anyway, Thanks I can continue coding the app now 🙂



Answers (2)

Answers (2)

hofit_koren
Explorer

Hi,

You will get this error - (and it will not save your UI5 settings) in case your project is not in the correct structure, or in case your neo-app.json is also not as we expect it to be.

Is it possible to attach your project or to send it to my email - hofit.koren@sap.com?

Thanks,

Hofit

former_member514516
Participant
0 Kudos

I also have the same problem.. And I cannot find "SAPUI5" in the Project Settings. Any help? Thanks