cancel
Showing results for 
Search instead for 
Did you mean: 

Webdynpro CAPTCHA error java.lang.NoClassDefFoundError

Sreejith1
Contributor
0 Kudos

Hi,

I was trying to test one CAPTCHA. So i followed the below blog

http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/4512

But i am getting an error

The initial exception that caused the request to fail, was:

java.lang.NoClassDefFoundError: com/octo/captcha/service/image/ImageCaptchaService

jcaptcha-all-1.0-RC3.jar & other jars are there in classpath.

I have added those as Used DC.

Any where we need to update the path???

Thanks,

Ram

View Entire Topic
Qualiture
Active Contributor
0 Kudos

If you did everything by the book with regards to creating an External library project, the only thing I can think of is you did your build incorrect.

How did you build your project? You should never use 'Create archive' or 'Deploy new archive and run' when using assembly type public parts. You should use 'DC Build' and 'DC Deploy' instead

Sreejith1
Contributor
0 Kudos

Hi Robin,You are right.

The one which i have tried was not working but when created new project with all precautions which he menthioned in that blog worked fine.Any idea about what exactly happening when we build in wrong way?