Showing results for 
Search instead for 
Did you mean: 

WebDynpro ABAP and Portal Navigation problem

Active Participant
0 Kudos

Hi all,

I've a problem with triggering Portal navigation from a custom WD4A application.

The request is to have an "Exit" button implemented and if pressed, the portal goes back to the top page:

--> Search

--> Kind of Search

--> WD4A -> Exit goes back to "Search"

I've tried using absolute_navigation/relative_navigation methods from interface if_wd_portal_integration, but they do not work at all.

It seems that the portal totally doesn't care about the request and remains still.

Methods are called passing the PCD of the "Search" page (i've tried even with the ROLES).

Anyone has an idea?

By the way, I was thinking about raising some kind of "standard" event like "navigate" or something...I don't know if it's applicable.

Thanks in advance,


View Entire Topic
0 Kudos


If you are navigating from one WD Application to another you can either use URL or Object Based Navigation.

In URL Method you can call the target application from the source application.

You can create the method in the Window of WD Component.

You also need to create exit plug (outbound) with parameter url (type string) and specify the plug type as Suspend.

Trigger this method as desired by you in your application.

CALL METHOD cl_wd_utilities=>construct_wd_url
      application_name = 'TARGET_APPLICAITON_NAME'
      out_absolute_url = lv_url.

 CONCATENATE lv_url '?sap-client=' sy-mandt '&sap-language=' sy-langu '
  INTO        lv_url.

    url = lv_url                              " string



Active Participant
0 Kudos

Hi Vishal,

Thanks a lot for your answer.

In fact I do not have do navigate to another application.

My goal is to navigate back to an EP service (in fact, to a specific link of the portal that respond to a specific PCD link).

I need to trigger portal navigation. I founded a lot of topics on how to use the IF_WD_PORTAL_NAVIGATION interface, but nothing that says how to "Leaving an embedded WD4A application". And standard methods absolute_navigation and relative_navigation simply do not work.

If I use the exit plug, the only result that I get it's an empty iView...



Former Member
0 Kudos

I encounter the same problem.

Where you able to solve this issue?

If yes would you like to share it to the community.