cancel
Showing results for 
Search instead for 
Did you mean: 

Web Service Provider Configuration

0 Kudos

Hi.! i Have the same problem, but i have not been able to fix the problem

View Entire Topic
RobertWaywell
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Antonio,

It looks like your issue will be a fair bit different from the credentials issue that Stefan encountered, so I have split the discussion.

With regards to your issue, the first thing that sticks out is a confusion between the ESP cluster port and the Web Service Provider REST port. These are 2 different ports that will be required and at the moment, you have edited the configuration try and have the project and the Web Service provider both use the same port. To clean that up, you need to do the following:

1) Figure out what port your ESP cluster is running on. If you are just starting it from ESP Studio by running a project, then the default port is 9786.

2) Remove the Project Binding that you set in the Project Configuration file.

3) In the wsp.xml file, confirm that the REST port is still set to use port 9091:

<webService enabled="true">

        <soapPort>9090</soapPort>

        <restPort>9091</restPort>

        <protocol>http</protocol>

4) In the wsp.xml file, set the "alloworigin" value to "*"

<allowOrigin>*</allowOrigin>

5) In the <DefaultCluster> section of the wsp.xml file set the port to either 9786 if you are using the default ESP cluster started by Studio, or set it to the port that your ESP cluster is actually using.

<DefaultCluster>

        <Hostname>localhost</Hostname>

        <Port>9786</Port>

Let us know what output you get from the WSP after making those changes.

0 Kudos

Hi, Now the error is "NetworkError"

with default port 9786 the error is "Error:NotFound"

RobertWaywell
Product and Topic Expert
Product and Topic Expert
0 Kudos

In the configuration section of the screen shot you just posted - what is port 9021 referring to? If that is supposed to be the REST port of the Web Service Provider, then it should be 9091.

What tool are you trying to connect to the Web Service Provider from? Is this Design Studio?

0 Kudos

Sorry, with the correct port 9091 the error is "Invalid Connection details" , The tool is Design Studio

the wsp.xml is:

<webService enabled="true">

  <soapPort>9090</soapPort>

  <restPort>9091</restPort>

  <protocol>http</protocol>

<allowOrigin>*</allowOrigin>

  <DefaultCluster>

        <Hostname>localhost</Hostname>

        <Port>9786</Port>

        <Workspace>default</Workspace>

  <Authtype>user</Authtype>

  <SslEnabled>true</SslEnabled>

RobertWaywell
Product and Topic Expert
Product and Topic Expert
0 Kudos

If you look at the output from the Web Service Provider, what is the exact error being reported at that level?

0 Kudos

Hi, Robert

Now it works fine, i change the parameter <SslEnabled>false</SslEnabled>

Thank you