cancel
Showing results for 
Search instead for 
Did you mean: 

Web Service Genrattion Error

Former Member
0 Kudos

Hi,

I was playing around with the ws generation tool and I actually was under the impression that I had successfully generated the service and deployed it to the server. The system actually finds the service when I go and search for deployed services on the server. When I try to test the service I receive the following error message:

Invalid Response Code: (404) Not Found. The request URL was:"http://nszh3020.zrh.sap.corp:50000/ratecalcrules/myRateCalcService". Check, whether the URL is correct, and the Web Service that you are requesting is up and running.

Here is what I did:

1) created rules project

2) Created dummy Web Module and deployed it to server

3) refereneced the dc BRMS FAÇADE and ENGFACADE/tc/bl/logging/api, ENGFACADE/engine.jee5.facade in rules DC and synched it.

4) built the whole lot and deployed it to the server

5) amended run.bat according to instructions

6) started the tool, made the entries and successfully created ear (at least that is what the tool told me)

7) deployed ear to the server

I am on JDK 1.5.0_16.

Any ideas ?

Accepted Solutions (1)

Accepted Solutions (1)

artigopalan
Advisor
Advisor
0 Kudos

Hi Andreas,

This problem is because you have been using an older version of CE.

I would suggest you to upgrade to the latest version available on SDN.

Regards,

Arti

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Andreas,

This problem is occurring probably because you are using an earlier version of CE 7.11 Beta. Recently, a newer build of CE 7.11 has become available for donwload replacing the earlier version.

We have tested internally with this version, and the WS tool works fine.

Another option here is to use this tutorial to generate the Web Service yourself.

See this link for instructions, https://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/c082390a-035f-2b10-dc9d-befec4af...

Thanks

Rajgo