cancel
Showing results for 
Search instead for 
Did you mean: 

Web Report Print Preview problem - urgent

Former Member
0 Kudos

After Clicking Print buttonn on the web report, i select Print Preview from IE Explorer and here the variable values passed to the print function in web template, are getting displayed and actually it is part of URL , getting displayed in the Print Preview.

any ideas ..

i have already cleared the value of title and footer in page setup.

and this is a junk data in the header in the print preview

it will be something like this,

User%20ID:%xyz%20printed%20 etc...

actually i am passing below values to the print function,

&P_FOOTER_RIGHT='+SYUSER + '&P_HEADER_LEFT='+REPTXTLG +

'&P_FOOTER_LEFT=' +INFOCUBE

Regards

Message was edited by: Shashi

Message was edited by: Shashi

Message was edited by: Shashi

Accepted Solutions (1)

Accepted Solutions (1)

former_member188975
Active Contributor
0 Kudos

Hi Shashi,

Have you tried passing '&SYUSER& '...

Former Member
0 Kudos

bhanu,

here is the part of the variables i am passing to print funtion,

&P_FOOTER_RIGHT='+SYUSER + '&P_HEADER_LEFT='+REPTXTLG +

'&P_FOOTER_LEFT=' +INFOCUBE,

i didnt understand ur answer, could u please elaborate more thanks,

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Shashi,

sorry, I have trouble to understand your question.

Do you have problems with the %20 value in your string?

This is the url escape code for the space (blank) letter. So there is a problem somewhere when unescaping the input. One suggestion could be to use the static method IF_HTTP_UTILITY~UNESCAPE_URL of class cl_http_utility. in method PROCESS_URL_PARAMETERS of the help service class to unescape the input.

Heike

Former Member
0 Kudos

Thanks for inputs,

actually i dont have problem with url escape part, actually i dont want to display this in my print preview of report,

i want dont want it to be displayed.