cancel
Showing results for 
Search instead for 
Did you mean: 

Web Page Composer - Displaying & Editing pages gives a runtime error

Former Member
0 Kudos

Hi,

After installing the WPC and placing the initial permission as described in <a href="http://http://help.sap.com/saphelp_nw2004s/helpdata/en/45/f91dd13c7a04aae10000000a114a6b/content.htm">defining permission in the portal content studio</a> end users (with the wpc_editor_role) can nicely create webpages, hence are not allowed to edit these pages (runtime error appears). This though they have onwership rights on the webpage... (The everyone group has "Full control" with end user permission )

By giving them administrator rights the issue is solved and the wpc functions beautifully, but after publishing the page, and taking away the administrator rights they are not allowed to see the page (white screen).

Does anyone have a suggestion to solve this issue...?

thx in advance,

Andre

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Andre -

The documentation is incorrect.

There is an updated SAP Note describing the correction.

Sorry, I can't remember the number, but the correction is this:

Incorrect documentation:

1. Navigate to Security Zones --> com.sap.nw.wpc --> pagebuilder

Correct documentation:

1. Navigate to Security Zones --> com.sap.nw.wpc --> wpc

This should solve the problem. It did for me.

Former Member
0 Kudos

Eric,

Thnx, I read the SAP note (1079797) and applied the needed permissions on the "medium_safety" and "no-safety" folders in the wpc folder. Unfortunately, with no result.

Rgds,

Andre

Former Member
0 Kudos

Issue solved!

As expected the issue was located in the permission settings.

Perhaps helpfull for you also,I resetted all permission and followed the following steps:

1. Are permissions for the PCD entry point set properly?

That is (if you use the recommendation for placing the iViews in a folder in PCD and provide entry point to it) in corresponding PCD folder, give e.g. read ermission to the 'everyone' group.

Activate the End User indicator.

http://help.sap.com/saphelp_nw70/helpdata/en/06/4776399abf4b73945acb8fb4f41473/frameset.htm

2. Are the general permission for WPC set correctly in Portal Content Studio?

http://help.sap.com/saphelp_nw70/helpdata/en/45/f91dd13c7a04aae10000000a114a6b/frameset.htm

3. Are the Initial Permissions for folders set correctly http://help.sap.com/saphelp_nw70/helpdata/en/a6/78aa5c2ab64c1d83db59a25793e9eb/frameset.htm

regards,

Andre

Answers (0)