cancel
Showing results for 
Search instead for 
Did you mean: 

Web Dynpro on Pocket PC

Former Member
0 Kudos
160

Hi All,

I am trying to access a simple web dynpro application from Pocket PC Emulator (2002/2003). Pocket Internet Explorer is not rendering the pages correctly. Do I need to make any configuration changes on the server side to enable device recognition ?

Thanks much,

Ravi.

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Ravi,

the server should automatically recognize the pocket IE by the user-agent of the browser. If it doesn't, you can force the usage of the dedicated pie client by adding the url parameter "sap.csf.client=PieClient", for example "http://<host>:<port>/webdynpro/dispatcher/local/wdserverapp/wdApp?sap.csf.client=PieClient".

Some of the UI elements of the "standard" browsers are not available for pie and will not be displayed (correctly). Please have a look at the NDS documentation.

Hope that helps.

Regards

Stefan

Former Member
0 Kudos

Hi Ravi, hi Stefan,

The URL parameter in order to activate the Pocket PC client is "sap.session.client=PieClient", I am afraid "sap.csf.client=..." will not work.

Some of the Web Dynpro UI elements have been extended to include renderer classes. These include:

Button, Caption, CheckBox, CheckBoxGroup, DropDownByIndex, DropDownByKey, Group, Image InputField, Label, LinkToAction, LinkToURL, RadioButton, RadioButtonGroupByIndex, RadioButtonGroupByKey, TabStrip, Table, TextEdit, TextView, TransparentContainer, Tray, ViewContainerUIElement.

Hope that helps!

Best regards, Karin

Former Member
0 Kudos

Hi Ravi,

Karin is right, i mixed this up with other csf-related url parameters. "sap.csf.client" will not be recognized and will therefore have no effect. Sorry for that.

Regards

Stefan

Former Member
0 Kudos

Stefan/Karin,

Thanks a heap for quick response. For some reason, WAS is not recognizing the device automatically. It started working after appending "sap.session.client=PieClient" to the URL.

Thanks,

Ravi.

Former Member
0 Kudos

Karin/Stefan,

Thanks a heap for quick response. For Some reason WAS is not recognizing the emulator automatically. It started working after I appended "sap.session.client".

Ravi.

Former Member
0 Kudos

Hi Karin/Stefan,

This is working now.

Thanks,

Ravi.

Former Member
0 Kudos

Hi Ravi,

Great! Just for your information: We will soon have Blackberry enabled as well!

Best regards, Karin

Former Member
0 Kudos

BTW, I am using Sneak Preview II.