cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Web-based transactions don't work on Solution Manager 7.1

symon_braunbaer
Participant
0 Kudos

Hello,

I just installed Solution Manager 7.1 on Linux and DB2. Though all the web-based transactions, like

solman_workcenter are not working.

1) I managed my local hosts file

2) I enabled all the /sap/bc services in transaction SICF

3) I googled, that it is necessary to setup the Solution Manager using the transaction solman_setup.

I tried to do it, but an IE window pops up prompting me to login (via popup). Afterwards, I am getting

the following error:


The website cannot display the page

HTTP 500
                                    

Most likely causes:

  • The website is under maintenance.
  • The website has a programming error.

The URL which tried to open is:

http://<hostname>:8000/sap/bc/webdynpro/sap/wd_sise_main_app

I went again to SICF, but I don't have an entry, called sap under /sap/bc/webdynpro. And everything in

/sap/bc is activated anyway...

Please help me to correctly configure my Solution Manager πŸ™‚

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Symon,

Activate all AGS service & Webdynpro under transaction SICF.

for few example:

  
  

/sap/bc/webdynpro/sap/ags_work_incident_man

/sap/bc/webdynpro/sap/ags_workcenter

/sap/bc/ags_workcenter/ags_work_appln

/sap/bc/ags_workcenter/ags_work_webgui

/sap/bc/webdynpro/sap/ags_work_trans_print

/sap/bc/webdynpro/sap/ags_work_incident_create_app

/sap/bc/webdynpro/sap/ags_work_change_man

/sap/bc/webdynpro/sap/ags_work_setup

/sap/bc/webdynpro/sap/ags_work_job_sch_man

/sap/bc/webdynpro/sap/ags_work_implementation

/sap/bc/webdynpro/sap/ags_work_bp_iterf_mon

/sap/bc/webdynpro/sap/ags_work_services

/sap/bc/webdynpro/sap/ags_rbe

/sap/bc/solman/nwbc/solmanwork

/sap/bc/webdynpro/sap/ags_work_gui_selection

/sap/bc/dal/demoA

/sap/bc/webdynpro/sap/wdc_wba_rfc_monitoring

/sap/bc/bsp/sap/wba_start_smdia

/sap/bc/webdynpro/sap/ags_work_gui_default_set

And also check if not there add below roles to user which you using now:

SAP_SUPPDESK_CREATE

SAP_SMWORK_INCIDENT_MAN

SAP_SMWORK_BASIC

Reference SAP Note:

834534

Thanks & Regards,

V Srinivasan

symon_braunbaer
Participant
0 Kudos

Dear Srinivasan,

thanks a lot for your advice, with a big delay, I am finding again time for this issue...

I've done exactly what you are describing.

I already had enabled all the services under /sap/bc/webdynpro/sap.

Hence, I had to activate just a few more.

I've also added the roles, which you recommended. Note 834534 is about Solution Manager 7.0,

hence it seems not to be applicable in my case, where I have 7.1. Despite of this fact, I went

quickly through it, but didn't find nothing, which would sound helpful.

I continued to experiment with webdynpro transactions - I copied the URL to firerox:

http://<hostname>:8000/sap/bc/webdynpro/sap/wd_sise_main_app?sap-system-login-basic_auth=X&sap-clien...

I noticed an error message in Firefox, which wasn't visible in IE:

500 SAP Internal Server Error

ERROR: Die URL enthΓ€lt keine vollstΓ€ndige Domainangabe (<hostname> statt >hostname>..). (termination: RABAX_STATE)

I don't know why it comes in German, when I have selected English as login laguage, but let me translate it for you - it says: This URL doesn't contain a complete domain entry...

So, to me it clicked, that during the installation, I had selected local installation (as I don't have a domain, this is just a VMware sandbox, which I am building at home).

So I added <hostname>.localhost to /etc/hosts and I've also set the profile parameter SAPDBHOST in my default profile to <hostname>.localdomain and then restarted the instance, but this didn't help, the URL remains the same.

I tried also appending .localdomain to the URL in firefox directly. First, it seems to be doing something, as I could see the yellow circle circling, but then it times out:

500 Connection timed out

PLEASE help me to solve this very confusing situation... I'd really appreciate it to have a working solution manager for studying and tests...

former_member183107
Contributor
0 Kudos

Hi,

Kindly update the icm/host_name_full parameter and DNS name on the Server.

Hope it helps.

Regards,

Himanshu

symon_braunbaer
Participant
0 Kudos

Hi Himanshu,

thanks for your suggestion, but it has only got worse:

When I start solman_setup, the URL in the newly opened browser now doesn't contain nor a hostname, neither a port:

http:////:/sap/public/myssocntl?sap-client=001

And solman_workcenter produces a dump:

Category           ABAP Programming Error
Runtime Errors     SNAP_NO_NEW_ENTRY

ABAP Program

Application Component  Not Assigned

Date and Time      00.00.0000 23:58:00
Former Member
0 Kudos

Hi ,

Please follow this note for main issues.

1869765 - Short dump is generated when navigating in transaction solman_setup with error ' Syntax er...

Just before implementing the note please read it.

for the error in Firefox check the below note.

1680616 - RABAX_STATE Solman 7.1 Basic configuration step 3.1

But i would suggest you to use IE Solman config.

For the german language set default language as en in the browser.

Please check the below steps.

  1. Please go to transaction Solman_Setup
  2. Select Technical Monitoring
  3. Select Solman Self-Monitoring (radio button on the left hand side)
  4. Monitoring & Alerting
  5. Self-Monitoring Configuration
  6. Configure and Activate

SFM.PNG

What happens when you run this url in IE or browser directly.

http://myhost.mycom.corp:Port/sap/bc/webdynpro/sap/wd_sise_main_app?sap-language=EN&sap-accessibilit...


Thanks

Rishi Abrol



former_member183107
Contributor
0 Kudos

Hi,

Your logs may be full...

  1. backup the transaction logs
  2. then adjust the database to gain space in your logs disk

Or else

use transaction ST14, enter SNAP as table name, select "delete data" and press on "activate and adjust".

This will drop and recreate the table so it's empty.

Schedule the housekeeping jobs by executing SM36 - Default Job to make sure your tables are reorganized frequently.

Regards,

Himanshu

symon_braunbaer
Participant
0 Kudos

OK, obviously I had put too much (partially wrong) profile settings from different sources.

Now I've reverted back to the profiles right after the installation and it behaves also this way.

I am attaching the screenshot of what happens, when I enter the URL proposed by Rishi.

When I click Log On and enter the password, the yellow circle is circling, and then I am getting

HTTP 500 internal server error:

The website cannot display the page

HTTP 500

Most likely causes:

  • The website is under maintenance.
  • The website has a programming error.

What you can try:


Refresh the page.


Go back to the previous page.


More informationMore information

Really going nuts about this... Why is it so hard to fix it ... ?

P.S.: OK, I tried a few more things, but still not getting it...

1) I've set my hostname to a FQDN - <SID>.localdomain

2) I've then set icm/hostname_full to this FQDN, as recommended in an earlier reply to my problem.

3) The URL in solman_setup becomes like this: http:////:/sap/public/myssocntl?sap-client=001

hence not having neither a hostname, nor a port in it.

So 2 questions are arising for me:

1) Do I really need to have a FQDN ? Or perhaps the problem is somewhere else...

2) When I am switching to a FQDN, perhaps I need to modify more parameters, as SAP is clearly

not able to define the hostname, and the URL is without hostname: http:////:/......

Former Member
0 Kudos

Hi,

Have you check this note.

1869765 - Short dump is generated when navigating in transaction solman_setup with error ' Syntax er...

What is the entry diaplayes in SMICM -> Service.

and y is it so difficult to entry the fully qualified host name. you only need to set these parameter.

icm/host_name_full = fully qualified host name

SAPLOCALHOSTFULL = fully qualified host name

Third thing if you are using host file entry. Please manintain the hostfile of your pc too.

Thanks

Rishi Abrol

symon_braunbaer
Participant
0 Kudos

Hello Rishi,

many thanks for answering me so fast !!

1) No, I did not check this SAP note, as the problem doesn't occur with the original parameters after the installation, it only occurs when I set icm/host_name_full.

Furthermore, the dump occurs on the solman_workcenter transaction, not on solman_setup.

2) I've set the 2 parameters, as per your advice. In smicm I see the following:

  Active Services

      No. Log                Service Name/Port    Host Name            Keep Alive Proc.Timeo Actv External Bind   ACL File

       1  HTTPS              44300                <host>.localdomain          1.200      1.200

       2  SMTP               0                    <host>.localdomain            120        120

BUT again, there is no hostname or domain in the URL, when I execute solman_setup (IE opens):

http:////:/sap/public/myssocntl?sap-client=001

When I don't set these 2 parameters, at least I am getting http://<hostname>:8000/sap/...

and something opens (the screenshot I posted yesterday)

3) I've put both <host> and <host>.localdomain in /etc/hosts right after the installation:

<IP> <hostname> <hostname>.localdomain

so I think there is nothing to maintain in /etc/hosts

4) One more question - what about the parameters SAPGLOBALHOST and SAPDBHOST in the DEFAULT profile? I've also tried to set them

to <hostname>.localdomain, but the result is exactly as I stated above - it doesn't change nothing πŸ˜•

OK, so, just to summarize:

With the original profiles after installation, where I only have <hostname>:

- solman_setup works, I get the picture, I click Log On, a popup appears, I enter the credentials, then the HTTP error 500 comes up

- solman_workcenter does NOT dump, I only get "This page cannot be displayed" into my SAP GUI

With icm/host_name_full set to <hostname>.localdomain:

- solman_setup opens the browser, but the URL is without hostname and port (see above)

- solman_workcenter dumps

With all the 4 parameters (icm/host_name_full, SAPGLOBALHOST, SAPDBHOST and SAPHOSTFULL set to <hostname>.localdomain) the behaviour is as in the previous case.

What else could I try to make it work ?? Please help me...

Former Member
0 Kudos

Hi,

I cant see any service running as http.

Please set http port parametre.

icm/server_port_<n>     = PROT=HTTP,PORT=8000,TIMEOUT=1200,PROCTIMEOUT=1200

n is 0,1,2,3 depends what is not used in the system.

You need only HTTP port to run ICM service and solution manager config.

Thanks

Rishi Abrol

symon_braunbaer
Participant
0 Kudos

MANY MANY T/saHANKS !!! That was the last problem, now it is working !!!!!

I must have made some domage or whatever, the profile was like icm_server_port_0 = \HTTP

No Idea where the \ has come from...

Now both transactions solman_setup and solman_workcenter are displaying correctly !!!

Just in solman_workcenter I have only one tab, but this is probably a functional issue...

Thanks once again !!

So, to summarize, there were 3 issues - FQDN, /bc/sap services in ICM and HTTP service icm_server_port_n parameter

Answers (5)

Answers (5)

0 Kudos

I need Solman server access 8892858291

Former Member
0 Kudos

Hello,

I have read the replies and noticed that some of the checks below were already suggested. But I kindly ask you to check again:

1) through t-code SMICM, check if your HTTP and HTTPS ports are active.

The HTTP should be already active by default.

In case the HTTPS is missing, you need to add parameter in the Instance Profile:

  • profile parameter: icm/server_port_<n>
  • Value: PROT=HTTPS,PORT=443$$,TIMEOUT=600

(where <n> is the next available port entry)

2) Check the FQDN.

Check if the profile parameter icm/host_name_full is correctly set. It should be <server>.<domain> (same as set in the server) (e.g.: server1.xyz.com).

3) Since the HTTPS connections require secure connections, the SSL should be configured through t-code STRUST.

Among the steps to configure the SSL, the following profile parameters should be set:

  • profile parameter: login/create_sso2_ticket
  • value: 2

  • profile parameter: login/accept_sso2_ticket
  • value: 1

Hope it helps.

Regards,

Daniel

symon_braunbaer
Participant
0 Kudos

Dear Daniel,

thanks a lot for your reply, but you are suggesting me quite advanced things, which I will possibly try later, but now I just need to have functioning Solution Manager.

The problem seems to be, that I don't have an HTTP port properly configured in ICM.

I was researching about HTTPS, but I've encountered, that its setup is quite complicated, hence I'll try it later.

Then - if FQDN is not mandatory, then I don't need it - this is just a sandbox system in a VM, no domains, no SAP support, no maintenance certificate, this is just to exercise at home.

SSL. STRUST, everything I might try to setup later - either if necessary, or as an exercise.

Now I need to just be able to user solman_workcenter, etc. in order to browse to through the menus and learn what is where.

I would be thankful if you start with the minimal things, that are mandatory for Solman's functionality.

symon_braunbaer
Participant
0 Kudos

Thanks for the answers, gentlemen!

@Billy - it is the standard level after installation - SAP_BASIS has SP level 09.

@Javier - thanks, this sounds like a cool tip, I'm gonna try it and let you know!!

bxiv
Active Contributor
0 Kudos

SAP_Basis doesn't dictate the stack level; what SP is your ST component currently at?

symon_braunbaer
Participant
0 Kudos

Sorry, Billy, you are right !! I have - ST Release 710, Level 0004.

bxiv
Active Contributor
0 Kudos

You may have better luck if you updated to ST lvl 8, currently you are at the service release level that was made general for all customers.  Later this year ST 10 is going to be released, it may be a smoother transition from 8 to 10 vs 4 to 10.

symon_braunbaer
Participant
0 Kudos

Dear Billy,

thanks a lot for your reply... Is it possible to update just the ST component ? Or more components will need to be updated ?

But now I realized, that I can't update, as I don't have a maintenance certificate... πŸ˜•

bxiv
Active Contributor
0 Kudos

The components are all tied together, if you are missing any pre-req the process will fail.

You can obtain a new certificate from the market place if you browse to your system data.

Former Member
0 Kudos

Hello,

Have you activated all relevant HTTP Services? Please use transaction

SPRO -> Solution Manager -> Basic Configuration -> HTTP-Services

Regards,

Javier

symon_braunbaer
Participant
0 Kudos

Dear Javier,

I just checked that, and unfortunately, I don't have the HTTP Services menu.

Under Basic Configuration, I only have:

- Import Central Correction Note

- Basic Configuration: Guided Procedure

I tried to click on Basic Configuration, but again an IE window pops up and after the login, I am getting the error, stated above... Please advise !!

Former Member
0 Kudos

Hello Symon,

please follow steps of note  1245200 to double check the configuration.

Note 1245200 - DBA: ICF Service-Activation for WebDynpro DBA Cockpit

Please also implement corrections of

Note 1524302 - DB6: WebDynpro DBA Cockpit fails if sap is in the hostname

via transaction SNOTE.

Regards,

Javier

symon_braunbaer
Participant
0 Kudos

Dear Javier,

muchas gracias for your reply and suggestion !!

I did the recommendation from the note you recommended, especially the SICF_INST transaction,

as you can see in the other entries of this thread, I already did the other parts of the note...

Though, unfortunately, this didn't solve my problem. Please kindly check my reply to Srinivaran below for further details.

Thanks a lot !!

bxiv
Active Contributor
0 Kudos

What stack level is your SolMan currently running?  Do you see any errors in the MMC?