cancel
Showing results for 
Search instead for 
Did you mean: 

Warning printers in SM21.

Former Member
0 Kudos

Hi,

i am getting this type of warnings

in SM21 transaction as "Printer SSPS Temporarily Locked Due to Connection Problem".

How I can resolve?

Regards.

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Hello,

You set the values in rz10 for the instance profiles which handle printing (if you have multiple instances check SPAD for the problem printer to get the Spool Server). Neither are dynamic values so you need to restart SAP for the new values to take effect.

You set them to whatever you're comfortable with.

It will lock the printer after rspo/lpq/temp_disable_slow in seconds (releasing the spool work process) and unlock it after rspo/lpq/temp_disable_time in seconds. Normally it locks the printer for 300 secondes after 30 seconds of no response. I'd be reluctant to reduce disable_time below 300, so you should try increasing disable_slow to 60 seconds, and if that doesn't work maybe 120. But if you go over 60 and it's not a WAN connection I'd say your network people should look at the connection and your system folks should check the print server. You may also want to add another spool work process (rz10: rdisp/wp_no_spo) so the longer waits don't impact your other print jobs.

Do not set disable_time to 0. If you do, a bad connection could lock up all of your spool work processes and NOBODY would be able to print to ANY printer.

Michael

Former Member
0 Kudos

Hello,

If you double click on the line in SM21 it should give you the information you need. In case your version so SAP doesn't (I'm on ECC6) here it is:

The host spooler is responding too slowly to queries about print request. As this can decrease performance, the specified printer has been temporarily locked. If this occurs often for this printer, the querying at host spooler option should be deactivated. You do this in Transaction SPAD -> Output devices.

The parameter "rspo/lpq/temp_disable_slow" is used to set the maximum response time allowed. The parameter "rspo/lpq/temp_disable_time" is used to set the temporary lock time.

Basically, you've got a network problem. I see this all the time with the connection to our China print server (I'm in Canada). It locks the printer to keep from wasting bandwidth with a non-responsive device. Either turn off querying or adjust the parameters. Or get a better connection.

Michael

Former Member
0 Kudos

Hi,

I have found a SAP Nota that one refers just to these parameters. How and where I modify these parameters? and to how much I would have to set up them?

Regards.

Former Member
0 Kudos

Hi

Goto SPAD, and select output devices, check the printer name and double click on it, the on the first tab at bottom you will find, lock printer in SAP system.

Check if that entry is marked or not.

regards

Rahul

JPReyes
Active Contributor
0 Kudos

Hi Diego,

I presume SPSS is the shortname of a printer in your system... you can check that in table TSP03...

I presume this error is coming from a job running in your system that might be calling (for some reason) the printer.

Regards

Juan

Former Member
0 Kudos

Hi,

The entry exists in the TSP03, but it is not present some job in error.

Regards.

JPReyes
Active Contributor
0 Kudos

If the printer exist is TSP03 then check if the printer config is correct at SPAD...

Regards

Juan

Former Member
0 Kudos

The printer config is correct in SPAD.

Regards.

JPReyes
Active Contributor
0 Kudos

The only thing i can think on is that the printer is hard coded incorrectly in some program???....