Showing results for 
Search instead for 
Did you mean: 

WAD 7.0 Template Transport Issue

Former Member
0 Kudos

Hi All,

I have a problem when I attempt to transport my newly modified BEx WAD template up to our QA environment. I am the first person in our environment to try transporting a customized 7.0 template.

I copied the 0ANALYSIS_PATTERN Web Application Designer 7.0 default template to YMMPUR_ANALYSIS and changed it by adding a CONDITIONS_LIST, and INFO_FIELD item and changing some checkbox settings and it runs fine in our development system by specifying the TEMPLATE=YMMPUR_ANALYSIS in the URL for various queries. At this point all seems well to use this additional template as an alternate one for some of our queries.

The problem comes when I go into the RSA1> Transport Connection, using object type of BEx Web Template (BTMP), choosing my new template YMMPUR_ANALYSIS to pull over to the right, and gather all the necessary objects. I get a red status code in the window below with the message, "Message not found (in main memory)" and I get a list of other templates with their checkboxes checked as if I need to transport them up to our QA level as well as my newly modified one that uses those other templates. However I know those other templates are already in our QA environment. I get the same exact error situation after I copy the standard web template to another name and pull it over to the right in the transport connection without making any changes at all in it. I still get the message that a message is not found and these other templates are checked indicating to me that the system thinks I need to transport them up. I don't want to transport them up. All I want to do is to transport my template which uses these other templates just like the default one.

The BEx Web Templates mentioned to transport up are: 0ANALYSIS_PATTERN_EXPORT, 0ANALYSIS_PATTERN_FILTER, 0ANALYSIS_PATTERN_FOOTER, 0ANALYSIS_PATTERN_HEADER, 0ANALYSIS_PATTERN_INFO and the BEx Web Item 0PATTERN_BARCHART_SWITCHED. They already exist in our QA level, so why is the transport connection telling me it is necessary to transport them up and why the error message?

What am I doing wrong?

Thanks for your assitance. I would really appreciate it.



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

I have seen this behavior too - nothing to be worried about. But when I first got this message - i transported other templates too that the system was complaining about. But the second time I was transporting other one - i just ignored the messages and just moved the custom one and worked just fine in Q. So I guess just ignore the messages and send just your template.

Answers (0)