cancel
Showing results for 
Search instead for 
Did you mean: 

Visual Studio 2013

Former Member
0 Kudos

Hi,

I installed VS 2013 update 2 and, then, the executable support pack 9 (v. 13.0.9.1312) of SAP CR, downloaded from snc.sap.com/docs/DOC-7824.

The template of CR does not appair when I open a CR report or when I want add a new CR report.

I have already re-installed the support pack.

I have also VS 2010 and MS-SQL 2014 standard on my PC.

Can you help me ?

Thans.

marco

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Marco,

To be clear you installed this one correct:

http://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_13_0_9.exe

Is this a Windows desktop or WEB app?

If you create a new Windows Form Project and add the CR Viewer to the form can you then add or create a new report?

Need more details on steps to reproduce the issue.

Also, make sure your AV software is not blocking craxddrt.dll and crviewer.dll from being loaded. Use Porcess Monitor to see what happens when you try to open/load a report.

Also, if you had CR for VS installed for VS 2010 you have to uninstall and then re-install after VS 2013 was installed. A repair install will not update both VS 2010 and VS 2013.

Curious if VS 2010 works for you?

Don

Former Member
0 Kudos

Hi Don,

I installed the CRforVS_13_0_9.exe file of the link you wrote.

This is a web app

I created a new Windows Form Project and the problem is the same: there isn't the crviewer control in toolbox and a new report creation dont show me the cr template.

In an existing project the cr files appears with the notepad icon and are opened by default  with notepad

I turn off AV (kaspersky pure 3.0) during the setup of CRforVS and during the use of VS.

Using VS 2010 there are no problems: the reports are edited correctly (also the notepad icon appear on the rpt file)

marco

0 Kudos

In a Windows app you have to add the CR Viewer to the tool box by right clicking on it and Choose Item:

Then browse to the Viewer and selecting version 13 then you'll see it:

Now when you drop the Viewer onto the form it should add the engine and shared:

I've added the RAS assemblies...

Now when you add an existing Item to your Project you should see this option:

And select Crystal Reports, browse to your report and OK.

Now you should see this:

If you see a NotePad Icon then the DDE command for the file type is not hooked into craxddrt.dll

For WEB app's there are known issues with IISExpress and how you create the WEB app. If you create a blank WEB form from the template list then you'll have problems.

Search, there are posts on this issue.

Don

Former Member
0 Kudos

Hi Don,

I have done everything you have vritten

you can see that there is not the CrystalReportDocument icon.

I had to manually add CR references and loading an exesting report the dialog box doesn't show the *.rpt template

The project use the .net framework 4.5 and CR directory is for .net framework 4.0

In the "add new item Windows there is not the cr template:

marco

Former Member
0 Kudos

Hi Don,

I have reinstalled CRforVS_13_0_0.exe.

Does not seem the setup have been installed templates neither the CR editor.

marco

0 Kudos

That would be because you installed the original release.

VS 2013 is not supported until SP 9, use CRforVS_13_0_9.exe.

Don

Former Member
0 Kudos

Hi Don,

there was a previous release of SAP CR for VS installed (VS.2010).

I thught that this version (13_0_9) would remove the previous installed version.

I removed the previous version and installed the 13_0_9 version: now all is ok.

Thanks for your help.

marco

0 Kudos

It does remove the previous install but SP 9 will integrate into both versions of VS. Actually it will integrate into VS 2010, 2012 and 2013.

Have a great day

Don

Answers (3)

Answers (3)

Former Member
0 Kudos

As OS I have Windows 7 professional SP1 build 7601

Former Member
0 Kudos

Hi, Bhushan,

VS 2013 professional , Version 12.0.30501.00 Update 2

former_member188030
Active Contributor
0 Kudos

Hi Marco,

What edition of VS 2013 are you using?

- Bhushan