cancel
Showing results for 
Search instead for 
Did you mean: 

View Reports Process infinitely on SAP BOE server

Former Member
0 Kudos

Issue:

  1. 1. Running Crystal Server 2013.

  1. 2. Published Reports that fetch data from SQL server. Verified that reports run in Client.

  1. 3. When I log into CMC => Folders and "View" report in browser, the new browser simply "waits" (see attachment).


Steps Preformed:

  1. Created a new report that had no data. Simply added a text box the behavior was identical - ran successfully as RPT but would not allow viewing.

    2. Tried restarting and recreating all the All the Crystal Report Serves. No Luck.

    3. Configured trace High on the Document Processing Server and Cache Server.

Accepted Solutions (0)

Answers (1)

Answers (1)

Toby_Johnston
Advisor
Advisor
0 Kudos

Hello,

Are you connecting through a load balancer?  If so, try connecting directly to Apache Tomcat (or your WAS server) and view the report.

Can you view sample reports as provided by default?

Can you schedule your report to success?

Can you refresh the report in the CR Client but installed on the server?

Do you have another environment where you can view Crystal Reports (a sandbox environment for example)?  If so, connect to this other working environment Tomcat, but then log onto the CMS where you can't view the report.  This will tell us whether the problem is with the Web Application or on the backend.

Regards

Toby

Former Member
0 Kudos

Hi Toby,

Thanks for your quick reply.

Please find the answers below :

Are you connecting through a load balancer?  If so, try connecting directly to Apache Tomcat (or your WAS server) and view the report.

No , We are not connected to the load balancer at this point.

Can you view sample reports as provided by default?

Not able to view the sample reports as well.

Can you schedule your report to success?

Yes, Report is scheduled to success.

Can you refresh the report in the CR Client but installed on the server?

Yes, we can Refresh the report in CR client on the Server

Do you have another environment where you can view Crystal Reports (a sandbox environment for example)?  If so, connect to this other working environment Tomcat, but then log onto the CMS where you can't view the report.  This will tell us whether the problem is with the Web Application or on the backend.

Sorry , we have only one environment for now.

Today Something has changed, Please find the snap shot attached.

Thanks in advance for helping us out.

Prateek

former_member185603
Active Contributor
0 Kudos

Can you check if the server has enough memory?

Former Member
0 Kudos

Hi Jawahar

Yes we have 8 GB available memory and 5 GB free memory approximately.

Thanks

Former Member
0 Kudos

One More thing , In the trace for crystaldocumentprocessingServer the following error comes when ever I run the report:

received exception from getProcChildWorker()

Thanks

Toby_Johnston
Advisor
Advisor
0 Kudos

Hi Prateek

The problem seems to be with the Crystal Report Viewer connecting to the CR Cache and CR Processing Server.  Do you eventually get an error message if you let it spin?  Can you view a Crystal Report from the BI Launchpad?

Can you run a Landscape Report (choose only Server & Services analysis) against this environment and attach the ZIP file here or email it to me?  The problem you are facing could be with the command-line parameters of the CR Proc Server and the report will provide the necessary details on this.

An E2E trace would also be very useful for diagnosing the problem.  I would run a trace while trying to view a report in the BI Launchpad and make sure you collect and zip up the BI Launchpad web application logs along with the CR server side logs (this should let us see why the viewer can't complete the request)

http://service.sap.com/sap/support/notes/1861180

Beyond that, you could shutdown Tomcat and try to undeploy and redeploy the Web Applications using WDeploy GUI tool.  https://service.sap.com/~sapidb/011000358700001237082010E/xi4_webappdeploy_win_en.pdf

Regards

Toby

Former Member
0 Kudos

Hi Toby,

Thanks for helping me.

No Error Message if I let it spin. I can't view crystal Report from Launchpad as well.

Please find the landscape report and the trace in your email.

I will try to redeploy. Lets see if it resolves the problem.

Thanks

Prateek