cancel
Showing results for 
Search instead for 
Did you mean: 

VC Model Transport to QA from Dev

Former Member
0 Kudos
64

Hello!

I have a model that I created on DEV and deployed with "deploy model with PAR" checked. Also created a role from this iView. I have also transported the model and the iView+role from DEV to QA using transport package export/import mechanism. As expected my iViews won't work anymore on QA portal.

I have researched on SDN and found few forum postings regarding this issue. The resolution was to download and upload the par files from DEV to QA. I went in to Sys Admin -> Support -> Browse Deployment and searched to find the par files without luck. I found all my com.mycompany.QKW.My_Sales_iView folders but they don't have .par or .par.bak extension. I tried downloading them and adding the .par extension and later uploaded them onto QA but the upload fails as its the not really a par file.

Where do I go in Sys Admin -> Support -> Browse Deployment to find all my par files deployed using VC?

Thank you,

Kiran

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello

I think I have the same issue

I'm working with EP7.0 SP14 and I can't find the par deployed in development...

"compiler" options in VC are set as below:

Runtime = Webdynpro (Flash and Xgraph are not working)

Deploy model with PAR is checked

default value for other parameters

Deployment on development is working fine even if I don't see the new iview in the folder "Visual Composer - Models"

I've search in "System Administration - Support - Portal runtime" without success.

I would like to avoid to export/import the program and deploy with VC in validation and production environment.

Any idea

Former Member
0 Kudos

Hello

we've found what was my issue. I hope it can help some of you:

I has only "read" write in the folder "Visual Composer" of "content administration" so the deployment was not performed 100% successfully but without any error message.

Now I have full permission on it and it's working.

Regards

Benoit

Former Member
0 Kudos

Delporte,

To insure your vc par files get transported, check with basis to see if they have configured the transports to filter out com.sap objects.

The default deployment folder location for visual composer is pcd:portal_content/com.sap.gm.cnt/vcmodels

If they are filtering out com.sap objects, you should relocate your models to a different location in your pcd.

You have to change this on your model using Tools, Options, Compiler from the VC menu.

Regards,

Mark

Former Member
0 Kudos

unfortunately I went too fast ...

Indeed the deployment in development is working better (I see the created iview in the folder "Visual Composer"), but my PCD transport (menu System Administration - Transport Packages - Export) still contain only the iview.

I still don't have my application transported...

I've seen in the sap-help, that there is a setting at the portal level to define if the par should be transported inside the epa or not. But they say it's not always a good idea to do it, and once done, we should not change...

I put no filter in my transport package to follow your advice but without success...

so I still looking for a way to transport my application from DEV to VAL.

I search all files .ar created today but I only found some .jar (only 1KB and empty). I also have a .wda but only 7Kb...

Help...

Visual Composer is great but the transport... grrrrr

Thanks !

Former Member
0 Kudos

When you create your Portal Transport Package and add the Visual Composer iView to it, is your "Resolve References" property set to yes? (Must be Yes to include the .par file)

When you click the Export button, do you see the .par file listed in the export preview list?

We must have the setting you indicated because the .par file is getting included inside the .epa file for us.

Mark

Former Member
0 Kudos

As Mark points, you need to fill up the filter parameter for the Transport package Export settings. This filter takes comma separated values so you need to add your "com.mycompany.*" to it and also should have mentioned "com.mycompany" as the PAR name prefix while modeling the application.

Hope that helps,

Kiran

benot_delporte
Explorer
0 Kudos

Thank you for your help.

Yes my transport order is configure with "resolve references" = Yes and "Reference filter" = * (I tried also space)

But when I try the "export preview" the .par is not there

I also check this parameters (see [http://help.sap.com/saphelp_nw70/helpdata/EN/d6/772240da03e569e10000000a155106/content.htm|http://help.sap.com/saphelp_nw70/helpdata/EN/d6/772240da03e569e10000000a155106/content.htm] for more information). But it's empty so .par should be included in the epa.

Also, the parameter Pcd.TransportApplication.ProtectedNamespaces = com.sap.portal, com.sap.km, com.sap.netweaver.bc . So I don't see any restriction for VC

now I'm lost.

I though that Visual Composer was a great tool. which is right if we stay in the development environment... ;-(

Any other idea is welcome

Have a nice day anyway

Benoit

Former Member
0 Kudos

Benoit,

What do you have it as for "PAR Prefix" under Tools-> Options -> Compiler?

Regards,

Kiran

benot_delporte
Explorer
0 Kudos

I have corp.eurocopter.VC

any idea ?

Former Member
0 Kudos

In the reference filter, can you put this along with com.sap.* with a comma separating?

Kiran

benot_delporte
Explorer
0 Kudos

Hello

I try with References Filter = ,com.sap.,corp.*

but I still only have the following object in my export:

- webdynpro iview

- folders automatically created by Visual Composer during the deployment in development

- the model

To find a workaround, I tried to export from VC dev and import to VC validation but the deployment put the mess on the validation server (we have several instances with several J2ee nodes). I had to remove the application.

Any other idea ?

Regards

Benoit