Showing results for 
Search instead for 
Did you mean: 

Value Help Leading Zeros

Former Member
0 Kudos

Hi Folks,

again another difficult question.

We got an inputfield type matnr with a valuehelp S_MAT1 an a OUTPUT_002 conversion exit.

Now we developed a new value help which is also easy selecting from mara.

BUT the returned value is displayed with leading zeros AND our conversion Exit is ignored by the system.

We tried to use our serchhelp in a Collective Search Help and there it worked with the exit.

The Problem is not the Exit. In Standard Gui everything works fine with the normal, our, and the new collective search help.

But in WD it doesn't work.

Some Ideas ?

Thanks & Best Regards

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Michael,

IF your field is of type Numc type then you can using the attribute formatting property "Zeros as blanks". Refer to the link below -

[Supress Leading zeros for numberic fields using Attribute Formatting Property|]

To programatically change the formatting property use the the below code -

DATA lo_node TYPE REF TO if_wd_context_node.
DATA lo_node_info TYPE REF TO if_wd_context_node_info.
DATA ls_zeros TYPE wdy_attribute_format_prop.

ls_zeros-null_as_blank = 'X'.
lo_node = wd_context->get_child_node( 'FILTER' ).
lo_node_info = lo_node->get_node_info( ).

name = '<Attribute Name>'
format_properties = ls_zeros ).

Hope this helps.



Former Member
0 Kudos

Hi Ravikiran,

thank you for your Answer.

The problem is not the leading zero, i tried this already.

I found out, that the FM CONVERSION_EXIT_MATN1_INPUT has been changed by his input and output parameters,

an the problem is there i think.

best regards

Answers (0)