cancel
Showing results for 
Search instead for 
Did you mean: 

UWL: Issue with displaying work items from ECC

Former Member
0 Kudos

Hi,

We are having a problem with the displaying work items via the Universal Worklist. For ECC work items, only the SAP Easy Access menu appears. This occurs only in certain office locations. It's not related to authorisations.

Looking at the network logs, when a request is succesful is appears as:

[Thr 1] MsHttpGetIcman: redirect to http://vapp3.sap.brm.pri:8070/sap(ZT0zTzBKU3hwZml3b3RwR1VDYjVrYzVRJTNEJTNEeUszUUFvVGJJbWZwbEFNTFN0UT...?okcode=%2Fn*SWNWIEX+p_nosecm%3DX%3Bp_action%3DEXECUTE%3Bp_wi_id%3D000000401648%3B&DisconnectOnClose=0&sap-client=001&sap-language=en&sap-accessibility=

When the request fails, we see the following in the logs:

[Thr 1] MsHttpGetIcman: redirect to http://vapp3.sap.brm.pri:8070/sap(ZT0zTzBKU3hwZml3b3RwR1VDYjVrYzVRJTNEJTNERmJMQmpqNUwlMkI4SzdhUUtCNm...

(i.e. missing the ?~okcode request)

Any assistance appreciated...

Many thanks.

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Problem solved.

Parameters were getting lost by the message server. Once we put a web dispatcher in front of ECC, the parameters were passed correctly.

former_member110461
Active Contributor
0 Kudos

Hi Kevin,

Hope you are well.

I've had it before where routers chop the URL if it is 'too long'. There is normally a setting. We also had a similar thing where it chopped part of the cookie because of it's size.

So perhaps something for you to look at.

Paul