cancel
Showing results for 
Search instead for 
Did you mean: 

UWL detail iView in new window

Former Member
0 Kudos
70

How can I configure opening UWL item detail in new window instead on same page. I tried to change XML configuration file xml.standard: action "viewDetail" with property launchInNewWindow="yes", but nothing happened.

Have you any suggestion or do I something wrong?

Thanks a lot

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

By default the iView or Page do not open a new window. To launch them in a new window and to control the window parameters the following should be added to the properties of <Action> node:

<Action launchInNewWindow ="yes" launchNewWindowName="sub" launchNewWindowFeatures =" resizable=yes,scrollbars=yes,status=yes,toolbar=no,menubar=no,location=no,directories=no"...>

Or they can be added to the <Properties> of <Action> node:

<Action...>

<Properties>

...

<Property name="openInNewWindow" value="yes"/>

<Property name="newWindowName" value="sub" />

<Property name="newWindowFeatures" value="resizable=yes,scrollbars=yes,status=yes,toolbar=no,menubar=no,location=no,directories=no"/>

</Properties>

</Action>

Hope that helps...points are appreciated.

Cheers,

Former Member
0 Kudos

Hi,

I changed <Action> node as you suggested, but nothing happened. UWL item detail still opens in the same page. Where can I find more documentation about XML configuration?

Thank for your reply

Cheers

Former Member
0 Kudos

Try configuring the UWL iView. There is a "Launch in New Window" property. There should be options for launching in a new window

Hope this helps...points appreciated!

Former Member
0 Kudos

Hi Raymond,

Thank for hint, I tried it and it doesn't help. Therefore I created OSS message.

Cheers

Miloslav Mil

Former Member
0 Kudos

While uploading the XML file make sure you chose "None – use as is" for "Adapt to system". And after you have uploaded the XML file, make sure you clear the cache before you test the changes.

~Shakeel

Former Member
0 Kudos

Thanks for hint, where can I find the option "None – use as is" for "Adapt to system". Portal version is 6.0.14.0.0 and KMC is 6.0.14.3.0. I released the XML cache and rather restarted portal server.

Miloslav

Former Member
0 Kudos

System Admin -> System Config -> UWL Admin -> UWL Content Config. When you select "Upload a Config and assign to one or more systems" and click start.

To release cache: Navigate to UWL admin and cache Admin iView on the same page. Click on "Clear entire cache".

~Shakeel

Answers (2)

Answers (2)

0 Kudos

Hi everyone....

did anyone succeed in opening a collaboration task in a new window?

I'm trying but without any result....

Any help?

Thank so much in advance.

Former Member
0 Kudos

Dear friend,

I have the same problem, does anybody got the solution to open a new window?

I follow the solution steps, but nothing happen. I make sure the configuration be imported successful, because I also change the columns. My EP version is EP6 SP12, is it workable in this version?

Thanks.

Cheng-Mu