cancel
Showing results for 
Search instead for 
Did you mean: 

UWL completed work items do not appear neither automatically either after refresh

former_member474499
Participant
0 Kudos

Hello Experts,

I created a specific view in UWL which contains the approved invoice with completed status, but this view isn't refreshed automatically.

I set the parameter refresh to "60" but it still does not work .

For more information about the configuration set, here is my configuration file:

<UWLConfiguration version = "1.0" >

  <ItemTypes>

    <ItemType Name="uwl.completedtask.webflow.TS00275253.SAP_ECC" connector="WebFlowConnector" defaultView="ViewTS00275253Completed" defaultAction="launchSAPAction" executionMode="default">

      <ItemTypeCriteria SystemId="SAP_ECC" externalType="TS00275253" connector="WebFlowConnector">

<CompoundExpression LogicalOperation="AND" defaultViewFilter="yes">

          <Expression Name="status" value="COMPLETED" comparator="Equals"/>

        < / CompoundExpression >

      < / ItemTypeCriteria >

.....

   </ ItemType >

  </ Itemtypes >

  <Views>

< View name = " ViewTS00275253Completed " referenceBundle = " completed_tasks " selectionMode = " SINGLESELECT " width = " 98% " supportedItemTypes = " uwl.completedtask.webflow.TS00275253.SAP_ECC " ColumnOrder = " isEscalated , CreatorId , CreatedDate , subject, priority, attachmentCount , dueDate , status, invoiceDate , OI , GROSSINVOICEAMOUNT , VendorName , VENDORINVOCIENUMBER , CODEACERTIS , Dyncol1 " sortby =" priority: desc , dueDate : asc , CreatedDate : desc " tableDesign = " STANDARD " VisibleRowCount =" 10 " headerVisible =" no " queryRange = " undefined" tableNavigationFooterVisible = "yes" tableNavigationType = " CUSTOMNAV " actionRef = "" refresh = "60" dueDateSevere = " 86400000 " dueDateWarning = " 259200000 " emphasizedItems = "new " displayOnlyDefinedAttributes = "yes" dynamicCreationAllowed = "yes" actionPosition = "bottom" >

.......

      <actions>

        <Action reference="defaultGlobalWizard"/>

        <Action reference="addToNavigation"/>

        <Action reference="removeFromNavigation"/>

        <Action reference="refresh"/>

      </ Actions>

    </ View>

Thank you in advance for your help.

Best regards.

Accepted Solutions (0)

Answers (2)

Answers (2)

former_member189925
Active Contributor
0 Kudos

Hi 

Firstly refer to the below help link and check if you have carried out the settings as per the link or not :

https://help.sap.com/saphelp_nw73/helpdata/en/76/2d95eaaa9a4476be6e54695aa76f91/content.htm

Then refer to the below KBA and perform the steps given under resolution part of it with the External Item Id.

2109969 - Refresh of Completed Items do not work - Is the work item really completed?

To find the External Item Id refer to the below KBA

1532883 - How to Enable the Support Information for Troubleshooting issues in the Universal Worklist (UWL)

Regarding different refresh options in UWL, refer to the below KBA

2024498 - Clarifying UWL Refresh Options

Regards

Santarshi Samanta

benjamin_herzig
Participant
0 Kudos

Hello,

we have no problems with completed workitems. We have problems with "normal" workitems which are ready to use. We can see them in our UWL. But there is no link / action? Therefore i need the "normal" configuration for this item types.

We, and our consulting partner, have no idea wich actions and parameters we have to set for the item types at SWFVISU or at the UWL Configuration (at Enterprise Portal).

We know how to configure - but we don´t know what.

http://help.sap.com/saphelp_nw70/helpdata/de/59/d516690e854c7090ae15bf492a869f/content.htm?frameset=...

former_member189925
Active Contributor
0 Kudos

Hi Benjamin

From your last reply and the screenshot, what I could understand is that the workitems are appearing correctly in the UWL view, but they are coming as a plain text instead of hyperlinks which can be clicked. Please correct me if I am wrong.

If that is the issue then the below KBA might solve it .

2030570 - UWL task appears as text instead of hyperlink

Regards

Santarshi Samanta

benjamin_herzig
Participant
0 Kudos

Hi,

yes there is no hyperlink. My problem is that i don´t know which action handler i have to use. Maybe someone here is using the task TS00275253 and TS00275278 and can share the configuration (action handler, default action).

Best regards,

Benjamin

benjamin_herzig
Participant
0 Kudos

Hi,

i need the configuration for task TS00275253 and TS00275278. Can you please share your Itemtype config including actions?

We have problem to find out which actions we have to use.

Thanx

Benjamin