cancel
Showing results for 
Search instead for 
Did you mean: 

Using MBT build tool to build CAP-project as .mtar file in local dev environment

DennisVdPluijm
Discoverer
0 Kudos

Hi all,

I seem to have a problem building a CAP project locally using the new mbt build tool.

Steps I took where:

  1. From WebIde Full Stack, create new project from template using the CAP template "SAP Cloud Platform Business Application". I did not configure the HTML5 Application Repository and did not create a web module. I did enable UAA and selected NodeJS + Hana DB 2.0 SPS 04.
  2. From WebIDE, right-click the newly created project and selected "Build with cloud MTA build tool". An .MTAR file is successfully build in WebIDE thus configuration seems ok I guess.
  3. Exported the project from WebIDE, and unzipped the project on my filesystem locally.
  4. I made sure to successfully install the make.exe tool and also installed npm package for mbt. Additionally I already had installed @sap/cds-dk (not sure that is important)?
  5. Next I ran the command from the root of the project: "mbt build -p=cf --strict=true".

I am endlessly waiting for the process to complete, after 10 minutes I get a timeout. I tried a few other things... First execute the command "mbt init" and then use the command "make -f Makefile.mta p=cf -d". That gives a lot more debug information... but what happens when the dots are printed remains a mystery to me.

Any help on how to proceed is very much appreciated.

Accepted Solutions (1)

Accepted Solutions (1)

mariusobert
Developer Advocate
Developer Advocate

Hi Dennis,

you should be able to solve the issue by removing the "postinstall" script from the "package.json" file in the "db" module.

DennisVdPluijm
Discoverer

Hi Marius,

Indeed, I had to remove the postinstall from the package.json triggering the "node .build.js" and now is works for me.

Thank you!

Answers (0)