cancel
Showing results for 
Search instead for 
Did you mean: 

User Exit EXIT_SAPMRSRU_001 does not work

Former Member
0 Kudos

I created a virtual characteristics ZVIRTCHAR in a ODS

ZAMOEMP.

Added following Code in ZXRSRU02.

when 'ZAMOEMP'.

break-point.

l_s_chanm = 'ZVIRTCHAR'. "characteristic

l_s_chanm-mode = RRKE_C_MODE-READ.

append l_s_chanm to e_t_chanm.

Added follwoing code in ZXRSRTOP

data: g_pos_ZAMOEMP_ZVIRTCHAR type i.

Added following code in ZXRSRZZZ

form USER_ZAMOEMP using i_s_rkb1d type rsr_s_rkb1d

changing c_s_data type any.

FIELD-SYMBOLS <L_ZVIRTCHAR>.

break-point.

ASSIGN COMPONENT g_pos_ZAMOEMP_ZVIRTCHAR

OF STRUCTURE C_S_DATA TO <L_ZVIRTCHAR>.

<L_ZVIRTCHAR> = 'X'.

endform.

This is not working , I can not see the value "X" for

ZVIRTCHAR . The query always shows "#" for ZVIRTCHAR

Am i missing something ??

When I execute the query using RSRT

If I click on Generate Report it stops in Break-point of

ZXRSRU02 .

If i click on Execute , it never stops on any break-point.

It never stops in break-point of ZXRSRZZZ.

Any Help will be highly appreciated.

Thanks and Regards

Bhanu

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Please Ignore Posting . Problem is solved.

Former Member
0 Kudos

Can you please let me know how this issue was resolved. I have a similar problem

Former Member
0 Kudos

Issue is resolved.thx

Former Member
0 Kudos

I am having the same issue that you two were having. Can you please post the resolution that you found?

Thanks