cancel
Showing results for 
Search instead for 
Did you mean: 

User Authentication for a particular iView

former_member720137
Active Participant
0 Kudos

Hi All

I have a requirement wherein there is a SSO b/w portal and R/3 , but for a particular iView ( WD ABAP iView) i want user authentication ( a promt should come which will ask for username and password ) to happen. Can anybody tell me how can we achieve this?

I tried changing the Authentication Scheme of the portal to 'uidpwlogon' , but still it is not asking for user credentials.

Thanks in advance.

Regards,

Puneet

View Entire Topic
Former Member
0 Kudos

Hello Puneet,

Create a copy of the backend system that you have created in Portal System Landscape and set its Logon Method to UIDPW.

The iView(s) where you need login prompt, map this system in it.

This will fulfill both types of scenarios...iViews with SSO working and w/o Login prompts.

Regards,

Ritu

former_member720137
Active Participant
0 Kudos

Hi Ritu

My useriD in both the SAP systems are different. i want user should be authenticated at portal level only for this particular iView.

Regards,

Puneet

Former Member
0 Kudos

Hello Puneet,

This scenario is perfect for user mapping

Create a copy of the backend system in portal, set logon method to UIDPW.

Case 1:

If you want the user to enter the login credentials for backend system every time he/she accesses the iView, then dont set the user mapping for that user.

Case 2:

if you want the end user to set the mapping, then ask end user to do this setting by clicking on the Personalise link in portal masthead.

Case 3:

If you are aware of the user's backend credentails, then map this in User Admin.

Regards,

Ritu

Former Member
0 Kudos

Hello Puneet,

Please grant points if my replies have helped you resolve the issue.

Thanks,

Ritu

former_member720137
Active Participant
0 Kudos

Hi Ritu

My question is still not resolved , it is not asking for user authentication

Former Member
0 Kudos

If its not asking then something has missed.

Did you create the second system?

Did you change the logon method to UIDPW

did you map this system in that iView

if all the above is met, then it should ask for login prompt